#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2004
    Posts
    1
    Rep Power
    0

    ldap installation


    hi,

    have trouble installing openLdap.

    i'm running rh9
    openLdap-2.2.15
    BerkeleyDB.4.2

    while running configure i get "Berkeley DB version mismatch" error

    i ran configure with CPPFLAGS and LDFLAGS point to /include and /lib directories of DB installation with no success.

    it is also a correct version of database so problem lies somewhere else.

    what am i missing here?

    thank you,

    -dennis
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2004
    Location
    Stuttgart
    Posts
    50
    Rep Power
    11
    Maybe your DB Version needs to be patched...

    Our you have used the wrong libraries?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    12
    Rep Power
    0

    maybe this works for you 2?


    Hey,
    i had the same problems yesterday...
    try the following at your root prompt:

    #CPFLAGS=-I/usr/local/BerkeleyDB.4.2/include/db.h
    #export CPFLAGS LDFLAGS=-L/usr/local/BerkeleyDB.4.2/lib
    #export LDFLAGS
    #CFLAGS="-O2 -march=i486 -mcpu=i686"

    almost forgot about that:
    export LD_LIBRARY_PATH="/usr/local/src/db-4.2.52.NC/build_unix/.libs

    donīt have to tell ya to enter your own path to the source dir ;-)
    then run ./configure.....


    worked for me ...

    greets Marcel

IMN logo majestic logo threadwatch logo seochat tools logo