#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    3
    Rep Power
    0

    LDAP on OS X Server 10.3


    I'm running OS X Server and I'm try to set up the LDAP server so that I can access it and edit it with an LDAP client like LDAP browser or PHPLDAPadmin. I can't seem to connect to the server or login to it, although it is running. I suspect that it has something to do with the slapd.conf, ldap.conf and other configuration files. Any pointers or help with this. There is a Netinfo bridge built into the system. I really want to use it only to access the cn=users group and also a cn=people group that I added to maintain an address book.

    Thanks.
  2. #2
  3. Chris Larivee
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2003
    Location
    Littleton, CO
    Posts
    72
    Rep Power
    11
    Are you the administrator of said LDAP server? If so you should be able to specify a bind context or create a user with an ACL that would allow you permissions to edit lists through a browser. You should have specified an admin when you created the server - have you tried binding with that set of credentials?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    3
    Rep Power
    0

    Follow up


    Originally Posted by ldap4u
    Are you the administrator of said LDAP server? If so you should be able to specify a bind context or create a user with an ACL that would allow you permissions to edit lists through a browser. You should have specified an admin when you created the server - have you tried binding with that set of credentials?
    I would be happy to share the contents of my ldap.conf and slapd.conf files. Are there other config files that I need to worry about? I have been able to get the server running again, but I can't bind with any type of credentials. Help appreciated. I could set up a Webmin acount for you if you wanted to snoop around, although the File Browser doesn't seem to be working from a remote browser, probably the Java installed on the remote machine.

    /sds

Similar Threads

  1. win2k server, dns & ics giving me problems!
    By wildguy2k in forum Windows Help
    Replies: 2
    Last Post: October 12th, 2004, 03:06 PM
  2. Replies: 2
    Last Post: February 10th, 2004, 07:15 AM
  3. Lotus Notes Schema for Linux LDAP Server
    By seg_edv in forum LDAP Programming
    Replies: 4
    Last Post: January 13th, 2004, 02:43 PM
  4. Replies: 17
    Last Post: January 2nd, 2004, 03:07 AM
  5. open source ldap server for windows
    By bcurry in forum PHP Development
    Replies: 0
    Last Post: January 30th, 2001, 11:21 PM

IMN logo majestic logo threadwatch logo seochat tools logo