#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    0

    Ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1)


    I am very much new to LDAP. I had installed openLDAP 2.4.7 on FreeBSD. I am trying to create the database using ldapadd.

    /usr/local/bin/ldapadd -f /tmp/entries.ldif -x -D "cn=Manager,dc=my-domain,dc=com" -w secret.

    But it throws the error like
    ldap_sasl_bind(SIMPLE): Can't contact LDAP server (-1).

    I am running it using one program ( PUTTY ) from remote PC which is having Win XP OS.

    Give any clue to sole it.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2009
    Posts
    7
    Rep Power
    0

    Help : LDAP Server


    Hi, Even i am experiencing the same error, did anyone get an answer to this.?


    Regards,
    Sid
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2009
    Location
    Charlotte, NC
    Posts
    111
    Rep Power
    9
    you need to add -h hostname and if your not using the default port 389 then also add -p <port>

    /usr/local/bin/ldapadd -x -h <hostname> -p <port> -D "cn=Manager,dc=my-domain,dc=com" -w secret -f /tmp/entries.ldif
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Location
    Hungary
    Posts
    2
    Rep Power
    0

    Ldap sasl bind


    Hi all!

    This bind error "-1" occurs, when the default config file (/etc/ldap/ldap.conf) contains the default uri: "URI ldap://ldap.yourhost.yourdomain ldap://ldap-master.yourhost.yourdomain : port" . You have to hash-mark this line, and add this instead: "URI ldap://127.0.0.1", so the query will find the correct data automatically, or at least in my case, this was the only solution that worked. Set this, and try ldapsearch -x. If it works, you only have to create groups, users, etc. If you do not want to secure your ldap it's a good idea to turn off the TLS request too, so add this line to ldap.conf :
    "TLS_REQCERT never", if someone hadn't suggested before (I didn't read all the comments before). I hope it helps

    KAMA3
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Location
    Hungary
    Posts
    2
    Rep Power
    0
    Originally Posted by kama3
    Hi all!

    This bind error "-1" occurs, when the default config file (/etc/ldap/ldap.conf) contains the default uri: "URI ldap://ldap.yourhost.yourdomain ldap://ldap-master.yourhost.yourdomain : port" . You have to hash-mark this line, and add this instead: "URI ldap://127.0.0.1", so the query will find the correct data automatically, or at least in my case, this was the only solution that worked. Set this, and try ldapsearch -x. If it works, you only have to create groups, users, etc. If you do not want to secure your ldap it's a good idea to turn off the TLS request too, so add this line to ldap.conf :
    "TLS_REQCERT never", if someone hadn't suggested before (I didn't read all the comments before). I hope it helps

    KAMA3
    I've forgot to mention, to check all the "dc=" data in /etc/ldap/slapd.conf. The correct form should be (f.e is your domain is example.com) "dc=example,dc=com" or (if it's server1.example,com) "dc=server1,dc=exapmle,dc=com", at every line it occurs.
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2011
    Posts
    3
    Rep Power
    0
    Originally Posted by kama3
    I've forgot to mention, to check all the "dc=" data in /etc/ldap/slapd.conf. The correct form should be (f.e is your domain is example.com) "dc=example,dc=com" or (if it's server1.example,com) "dc=server1,dc=exapmle,dc=com", at every line it occurs.
    Hi I installed Open LDAP on Windows XP version 2.4.24. I configured a slapd config file and when I try to connect to the LDAP via WebApplication Server Community Edition via the Admin Console I receive the error can't contact LDAP server (-1). What am I doing wrong PLEASE HELP!!!

IMN logo majestic logo threadwatch logo seochat tools logo