#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2009
    Posts
    4
    Rep Power
    0

    Syncrepl not replicating


    I am running openldap-2.3.37 and berkley DB 4.4.20 on Redhat 2.6.18-92.1.1.el5

    Basically, I am trying to set up syncrepl on my systems for replication:

    LDAP is working fine but when setting up syncrepl nothing happens at all.

    On the provider it appears that the listening daemons are running;

    .
    .
    .
    Oct 14 11:29:53 infems1 slapd[19295]: <= bdb_filter_candidates: id=0 first=0 last=0
    Oct 14 11:29:53 infems1 slapd[19295]: <= bdb_list_candidates: id=0 first=1 last=0
    Oct 14 11:29:53 infems1 slapd[19295]: <= bdb_filter_candidates: id=0 first=1 last=0
    Oct 14 11:29:53 infems1 slapd[19295]: bdb_search_candidates: id=0 first=1 last=0
    Oct 14 11:29:53 infems1 slapd[19295]: bdb_search: no candidates
    Oct 14 11:29:53 infems1 slapd[19295]: send_ldap_result: conn=-1 op=0 p=0
    Oct 14 11:29:53 infems1 slapd[19295]: send_ldap_result: err=0 matched="" text=""
    Oct 14 11:29:53 infems1 slapd[19295]: slapd starting
    Oct 14 11:29:53 infems1 slapd[19295]: daemon: added 4r listener=(nil)
    Oct 14 11:29:53 infems1 slapd[19295]: daemon: added 7r listener=0x1bb62750
    Oct 14 11:29:53 infems1 slapd[19295]: daemon: added 8r listener=0x1bb63830
    Oct 14 11:29:53 infems1 slapd[19295]: daemon: epoll: listen=7 active_threads=0 tvp=NULL
    Oct 14 11:29:53 infems1 slapd[19295]: daemon: epoll: listen=8 active_threads=0 tvp=NULL

    Then it just sits there.




    On the consumer it starts up slapd and then just sits there as well:
    .
    .
    .

    Oct 14 11:31:25 infems2 slapd[31738]: @(#) $OpenLDAP: slapd 2.3.37 (Sep 8 2009 16:10:32) $ slaveserver:/usr/local/bin/openldap-2.3.37/servers/slapd
    Oct 14 11:31:25 infems2 slapd[31739]: bdb_db_open: Warning - No DB_CONFIG file found in directory /usr/local/var/openldap-data: (2) Expect poor performance for suffix dc=coremetrics,dc=com.
    Oct 14 11:31:25 infems2 slapd[31739]: slapd starting



    I have played with an endless amounts of configuration settings inside of slapd.conf without any success:


    ****************
    Here is the current variant that I have on the PROVIDER:

    # $OpenLDAP: pkg/ldap/servers/slapd/slapd.conf,v 1.8.8.7 2001/09/27 20:00:31

    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/core.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/cosine.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/nis.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/java.schema

    # Define global ACLs to disable default read access.



    pidfile /usr/local/var/run/slapd.pid
    argsfile /usr/local/var/run/slapd.args

    loglevel -1

    #sessionlog 1234 1000


    moduleload syncprov.la

    #######################################################################
    # ldbm database definitions
    #######################################################################

    database bdb
    suffix "dc=coremetrics,dc=com"
    rootdn "cn=Manager,dc=coremetrics,dc=com"
    rootpw secret
    directory /usr/local/var/openldap-data
    index objectClass,entryCSN,entryUUID eq
    lastmod on

    overlay syncprov
    syncprov-checkpoint 100 10
    syncprov-sessionlog 100


    *********************

    Now the slapd from the CONSUMER:


    # $OpenLDAP: pkg/ldap/servers/slapd/slapd.conf,v 1.8.8.7 2001/09/27 20:00:31
    file should NOT be world readable.


    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/core.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/cosine.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/nis.schema
    include /usr/local/bin/openldap-2.3.37/servers/slapd/schema/java.schema



    pidfile /usr/local/var/run/slapd.pid
    argsfile /usr/local/var/run/slapd.args

    loglevel -1



    #######################################################################
    # ldbm database definitions
    #######################################################################

    database bdb
    suffix "dc=coremetrics,dc=com"
    rootdn "cn=Manager,dc=coremetrics,dc=com"
    rootpw secret


    directory /usr/local/var/openldap-data

    index objectClass,entryCSN,entryUUID eq
    lastmod on

    syncrepl rid=123
    provider=ldap://master_servername:389
    type=refreshOnly
    interval=00:00:00:20
    searchbase="dc=coremetrics,dc=com"
    scope=sub
    attrs="*"
    filter="(objectClass=*)"
    schemachecking=off
    updatedn="cn=Manager,dc=coremetrics,dc=com"
    bindmethod=simple
    binddn="cn=Manager,dc=coremetrics,dc=com"
    credentials=secret

    I am using root for testing and this can be modified later.


    I am able to query LDAP on the provider server from the consumer server using the following method:

    ldapsearch -x -h master_servername -b dc=coremetrics,dc=com


    Can someone please point out what I am doing wrong?
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2008
    Posts
    85
    Rep Power
    6
    did you've received something or this command terminated quiet?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2009
    Posts
    4
    Rep Power
    0
    The ldapsearch returned the contents of LDAP on the other system. This was to make sure that a connection and query could successfully be made between boxes.

    The main issue is that for some reason the consumer is not initiating the replication from the provider. Both systems just sit there.

IMN logo majestic logo threadwatch logo seochat tools logo