#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2004
    Posts
    1
    Rep Power
    0

    ldap configure error ( BDB: BerkeleyDB version incompatible)


    Hi,

    I am getting the following error while configuring ldap server version( 2.2.15) on Linux .

    checking Berkeley DB version for BDB backend... no
    configure: error: BDB: BerkeleyDB version incompatible

    I have installed all the prereq's in /usr/ldap

    ie
    cyrus-sasl-1.5.28
    db-3.2.9

    and openssl comes with linux so is in /usr/local/ssl

    So this is what I am using to configure ldap server

    env CPPFLAGS="-I/usr/local/ssl/include -I/usr/ldap/include" LDFLAGS="-L/usr/local/ssl/lib -L/usr/ldap/lib" ./configure --prefix=/usr/ldap --with-wrappers

    I have been struggling with this since 2 days, could someone
    let me know what is happening here?

    Thanks for your help,
    Neel
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2004
    Location
    Stuttgart
    Posts
    50
    Rep Power
    11
    "Berkeley DB 4.2 (latest revision with patches) should be used with OpenLDAP 2.1 (and later)."

    Your Version (3.2.9) is just a bit too old... View the readme of your OpenLDAP Readme;

    and rtfm: http://www.openldap.org/faq/data/cache/44.html

IMN logo majestic logo threadwatch logo seochat tools logo