#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    8
    Rep Power
    0

    Cool LDAP error question? Can't Connect to Ldap server


    I've been trying to do an ldapsearch just to test ldap and I get can't connect to ldap server. I've also tried to run phpadmin, it too cannot connect to ldap server. When I run make tests it runs ok and everything is succesfult excpet the certificates at the end. Is there sometehing I'm overlooking here. I am new with LDAP, so it could easly be I just don't know what the heck I'm missing here.
    Thanks,
    Homer
  2. #2
  3. Psycho Canadian
    Devshed Demi-God (4500 - 4999 posts)

    Join Date
    Jan 2001
    Location
    Canada
    Posts
    4,846
    Rep Power
    635
    what are you running exactly? how are you testing it? etc..
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    8
    Rep Power
    0
    sorry about that.
    Fedora Core 2

    "make tests" all are sucessful

    /sbin/ldapsearch -x -b -h ' ' -s base '(objectclass=*)' namingContexts

    I get ldap_bind: Can't Connect LDAP server(-1)

    when I enter the ldap://ldap.myserver.com I get the search box popup.

    When I enter phpadmin.myserver.com I get cannot connect to ldap server
  6. #4
  7. Psycho Canadian
    Devshed Demi-God (4500 - 4999 posts)

    Join Date
    Jan 2001
    Location
    Canada
    Posts
    4,846
    Rep Power
    635
    a make test determins if it was installed properly not if it's running, look for a slapd.sh file that should be run to start it, I've never used ldap on a linux box (only bsd) so I'm not sure where it puts the file, but the installation help at openldap.org should help
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    8
    Rep Power
    0
    slapd is running and listening on port 389
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2004
    Posts
    2
    Rep Power
    0
    I was having a similar problem at one point. I manually deleted the databases and started over, and now LDAP seems to be working properly. (Now if I can just get Samba to talk to it...)

    Of course, if you have much data in your system, this may not be a good option...
  12. #7
  13. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2004
    Posts
    8
    Rep Power
    0
    No data at all this is a fresh install
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Posts
    1
    Rep Power
    0
    I had similar program


    when me type
    ldapsearch x b s base (objectclass=*) namingContexts


    openldap show me this error
    ldap_bind:Can't contack LDAP server(-1)

    before ldapserch everthing is ok

    what's wrong with it

IMN logo majestic logo threadwatch logo seochat tools logo