#1
  1. No Profile Picture
    Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2001
    Posts
    29
    Rep Power
    0

    Creative Labs Sound Blaster Live! sound card problem...


    first: hello

    I changed my sound card to a Creative Sound Blaster Live! on Linux Mandrake. Kudzu found it, uninstalled the old sound card, and installed the SB Live! card. Now the sound doesn't work! I've tried to run the sndconfig, but get errors. Here's the output:

    "Probe Results
    A PCI sound card was found in your system. The details are:
    Model: Creative Labs|SB
    Live! (audio)"

    Then sndconfig tries to play a sample, which i cannot hear...
    But then I get the error:

    "modprobe error
    The following error occurred running the modprobe program:

    /lib/modules/2.4.18-6mdk/kernel/drivers/sound/emu10k1/emu1
    0k1.o: init_module: No such device
    modprobe: insmod
    /lib/modules/2.4.18-6mdk/kernel/drivers/sound/emu10k1/emu10k1.o failed
    modprobe:
    insmod sound-slot-0 failed"

    Then I get the manual installation screen... I select "Sound Blaster Live!" but get the same error....

    Here's my modules.conf:

    alias usb-interface usb-ohci
    probeall scsi_hostadapter ide-scsi
    alias usb-interface2 usb-uhci
    alias usb-interface3 usb-uhci
    alias /dev/nvidia* NVdriver
    alias char-major-116 snd
    alias char-major-14 soundcore
    alias snd-card-0 snd-card-emu10k1
    alias sound-slot-0 snd-card-emu10k1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    if I run lspcu i get:

    00:05.0 Multimedia video controller: Zoran Corporation ZR36120 (rev 03)

    00:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)

    Then I run lspci -v and get:

    Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
    Subsystem: Creative Labs CT4780 SBLive! Value
    Flags: bus master, medium devsel, latency 64, IRQ 10
    I/O ports at e800 [size=32]
    Capabilities: [dc] Power Management version 100:06.1

    Input device controller: Creative Labs SB Live! (rev 0a)
    Subsystem: Creative Labs Gameport Joystick
    Flags: bus master, medium devsel, latency 64
    I/O ports at ec00 [size=8]
    Capabilities: [dc] Power Management version 100:07.0



    but I don't get any sound....

    please help!

    -tommyj
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2002
    Location
    Dalec HI
    Posts
    26
    Rep Power
    0
    you need to recompile kernel with proper sb module (read docs) and then try loading it

    I've seen people also have problem hearing sound, after setup, due to digital output.

IMN logo majestic logo threadwatch logo seochat tools logo