#1
  1. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14

    Getting sound to work


    OK this should be simple, because I'm just trying to get the Sound Blaster 16 (sb16) card to work under Linux (kernel 2.4.5). Now I've read that by default it's all compiled, so I just have to insmod it and it should work. Only it doesn't. When I run the following command, I get the following response:

    Code:
    $ insmod sb
    /path/sound/sb.o.gz: unresolved symbol sb_dsp_init
    /path/sound/sb.o.gz: unresolved symbol sb_dsp_detect
    /path/sound/sb.o.gz: unresolved symbol isapnp_find_card
    /path/sound/sb.o.gz: unresolved symbol sb_dsp_unload
    /path/sound/sb.o.gz: unresolved symbol smw_free
    /path/sound/sb.o.gz: unresolved symbol isapnp_find_dev
    /path/sound/sb.o.gz: unresolved symbol unload sbmpu
    /path/sound/sb.o.gz: unresolved symbol probe_sbmpu
    Now when I looked around some web sites, I found references to alsa sb16 drivers, and I even found an sb16.c file, but of course that's only one of many files required for an insmod. I would have thought though that all the files required would come as standard with the kernel, as one web publisher mentioned they were back in 2.2.16. So, not being a C programmer, can someone help me out with all those unresolved symbols? What do I do, short of a kernel recompile?
  2. #2
  3. No Profile Picture
    Roving Icicle
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2001
    Location
    Netizen
    Posts
    56
    Rep Power
    14
    What distro?
    Is it just me or is it cold in here?
  4. #3
  5. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14
    Slackware 8, and a fairly typical install at that.

IMN logo majestic logo threadwatch logo seochat tools logo