#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2001
    Location
    Belgium
    Posts
    39
    Rep Power
    14

    NIC with Debian-Linux


    debian version 2.2 (potatoe)
    PC 486DX
    **************************************************
    I have a problem installing ly NIC....

    manufacturer: SMC 8216T
    It is an ISA-Card.
    2 jumpers:
    - 3 modes (IRQ,IO,ROM)
    SOFT
    * 10,300,CC000
    3,280,D0000
    -2 modes (ROM)
    * SOFT
    D8000
    --> dont know what this is
    ****************************************************
    installed isapnp-tools
    ran pnpdump gets "No board Found"

    tried ne,ne2,tulip and all smc-drivers

    allways getting "Device or Resource Busy...."

    led on CARD for READ-data (Rx) flashes so it gets power from mobo


    any suggestions? i am desperate......
    Last edited by H@voc_!nc.; April 24th, 2002 at 04:05 PM.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    try to set all jumpers to soft-mode. but i think it is too old for plug and play and they have their own configuration program.

    if this is the case, then you need to set the card to fixed numbers. 10,300,cc000 looks ok. you need to tell that these resources are used by non-plug-and-pray-card (and thus are not available for pnp) in your cmos setup.

    for old isa cards you need to pass the parameters to your driver in linux. like "insmod smcxxx.o irq=10 base=300 mem=cc000"

    modinfo -p smcxxx will tell you all possible parameters.

IMN logo majestic logo threadwatch logo seochat tools logo