#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0

    Slackware 8 install -- last few problems


    I installed Slackware 8 the other day and I've been able to get almost everything working ok but I just have a few issues left.

    1. Video resolution -- I had to diable all but 800x600 just to get rid of the "virtual desktop" effect where my desktop is bigger thatn the screen. If I have 1024x768 listed in /etc/X11/XF86Config then the desktop is slways that size, not matter what the resolution. Any idea how I can get it fixed to allow multiple resolutions and ditch the virtual desktops? Strange thing is that there's no "Virtual" line in /etc/X11/XF86Config.

    2. Sound card -- I have an old SoundBlaster64 sound card that the system won't recognize. I adjusted the bios to give it IRQ 10 on startup because it wouldn't work under any other Linux distro either. Now it works fine under Red Hat and Mandrake for sure. How do I configure it for Slackware?

    3. Printer -- I'm running an SMC Barricade broadband router with a print server built in. How on earth do I get Linux to recognize it? I have a hard enough time getting a local printer installed!

    Well, there's the major problems. If anyone has any ideas, I'd definitely appreciate any help you can give! Thanks!
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0
    1. It's a Voodoo 3 card and I can get 640x480, 800x600, 1024x768 to all work but as long as I have 1024x768 as an option, I always get a desktop that's 1024x768 no matter what resolution I'm at.

    2. I'll try the MAKEDEV command when I get home. Thanks for the tip!
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    press ctrl-alt-minus. then you get 800x600 with virtual 1024, press again and you should have 640x480 with virtual 1024. again and you are back to the normal state. nice zooming effect

    i only know about X-win 3.x though. there you could not have a 800x600 without virtual 1024 if you had the 1024 also activated.

    maybe your distro disabled the hotkeys. afaik but most donīt.

    your smc, is this an external device? then look in the manual / manufacturers homepage which protocols it supports. if they donīt have documentation on this, you can ask mr.google and hope it is supported at all...

    you can just test it by installing the printer as remote printer in linux. (this is much less work than local printers!). does it have an ip address?

    most print servers implement ipp (internet printing protocol: linux, win2k/xp) or smb (windows). some even run a mini-unix themselves
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0
    Thanks M. Hirsch. I checked out the smc site and they have great documentation for setting up the print server in Windows (I got it working perfectly on my Windows box in under 5 minutes!). However, their linux/unix procedure reads like this:

    "Follow the traditional configuration procedure on Unix platforms to set up the Barricade print server. The printer name is lpt1"

    That's it! So I checked out some linux printing tutorials and promptly confused myself. The IP of the router is 192.168.2.1 and my Windows print setup works fine so I know that the router is working ok. Anyone know how to set this up to print?
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    this is enough info

    add this line to /etc/printcap:
    Code:
    printserver:sd=/var/spool/lpd/printserver:rm=192.168.2.1:rp=lpt1:bk:sh:mx#0:
    i canīt explain all entries (see "man printcap"), i copied this from the printcap that my suse distro created.
    you need to create the mentioned dir with 0775 and lp.lp (could differ for slackware!)

    if the "rm= " part does not accept an ip as remote server name, add an entry to /etc/hosts: "192.168.2.1 printserver" and replace the ip by "printserver"
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0
    Beautiful! Thanks a ton! I'll try it as soon as I head home tonight! So how will I know if it works? What command can I use to test it from the command line?
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    lptest|lpr -pprintserver

    lptest outputs lines of ABCDE...XYZ01234... and so on (test it!), output piped to lpr (the standard way of printing on linux), option -p says "use this printer:"

    always happy when people appreciate my help
  14. #8
  15. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0
    Perfect! I'll let you know how it goes! It's funny..I thought I was starting to understand Linux a bit more but I guess I have a ton more to learn. Good thing this board's here!
  16. #9
  17. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    110
    I agree with you on that last statement, tom!! I have just installed Slackware 8 at work and Red Hat 7.2 at home... Oh, the adventures I am having!!! M.Hirsch and co are great guys - imagine iif we were alone!!

    Christo
    This is me: http://chris.uk.com
  18. #10
  19. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Posts
    12
    Rep Power
    0
    Printer working! Thx a million M. Hirsch! I only had to change the line to this:

    lp|printserver:sd=/var/spool/lpd/printserver:rm=192.168.2.1:rp=lpt1:bk:sh:mx#0:

    and add it to printcap! Now to get the sound card working!

IMN logo majestic logo threadwatch logo seochat tools logo