#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2001
    Posts
    1
    Rep Power
    0

    Telnet Problems in Mandrake 8.1


    Can't seem to get my telnet client to work in Mandrake 8.1.

    Can connect to a server, however the carriage returns look strange, and after I enter my username and hit return...nothing...frozen...

    Are there some settings somewhere that I have to tweak?
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 1999
    Posts
    52
    Rep Power
    16

    Exclamation Mandrake


    The first thing to do is to evaluate if what you need to do can be done with ssh instead of telnet. I strongly recommend against using telnet over a public network (eg the 'net).

    If Telnet is still what you need/want then first make sure that the telnet server is actually installed. Mandrake does not install this by default so you may need to dig out the CDs or download it from ftp. The rpm package is telnet-server-krb5-1.2.2-11mdk.i586rpm.

    Now see that it is enabled in xinetd in /etc/xinetd.d/telnet Look for a line disable=yes and either remove it or set it to =no

    The default config for Mandrake is to deny all except local host so you need to give explicit permission for each host that you want to allow to access the telnet server. One way is to use an only_from line in the xinetd telnet config file (see man xinetd). Alternatively add the hosts to the hosts.allow file (see the man pages)

    Also see: http://linuxdoc.org/

IMN logo majestic logo threadwatch logo seochat tools logo