Thread: apache error?

    #1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    6
    Rep Power
    0

    apache error?


    I'm running apache on Red Hat linux 7.2, I can see the files of the server
    in my browser, but other users can't, they receive the following
    message:"Alert!: Unable to connect to remote host.".

    Do you know why is this?

    Hope you can help me.

    Best Regards,
    Simao Mata
    Last edited by hurd; December 21st, 2001 at 05:55 PM.
  2. #2
  3. Modding: Oracle MsSQL Firebird
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2001
    Location
    Outside US
    Posts
    8,527
    Rep Power
    539
  4. #3
  5. phpkid ~~~~~~ :o)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Nov 2000
    Location
    NJ, USA
    Posts
    2,534
    Rep Power
    17
    They need to be able to connect to your machine.

    Check whether they are able to ping to your machine.

    JD
    _____________________________
    d.k.jariwala (JD)
    ~ simple thought, simple act ~
    I blog @ http://jdk.phpkid.org
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    6
    Rep Power
    0
    this is what the "dig" command returns (in their machine):

    [simovsky@alpha ~]$ dig bliter.net

    ; <<>> DiG 9.1.0 <<>> bliter.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32777
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;bliter.net. IN A

    ;; ANSWER SECTION:
    bliter.net. 300 IN A 213.22.30.62

    ;; AUTHORITY SECTION:
    bliter.net. 300 IN NS ns3.zoneedit.com.
    bliter.net. 300 IN NS ns1.zoneedit.com.

    ;; ADDITIONAL SECTION:
    ns1.zoneedit.com. 91012 IN A 207.228.252.101
    ns3.zoneedit.com. 91012 IN A 209.61.140.1

    ;; Query time: 110 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sat Dec 22 14:22:10 2001
    ;; MSG SIZE rcvd: 124

    [simovsky@alpha ~]$ dig 213.22.30.62

    ; <<>> DiG 9.1.0 <<>> 213.22.30.62
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 52203
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;213.22.30.62. IN A

    ;; Query time: 42 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sat Dec 22 14:22:29 2001
    ;; MSG SIZE rcvd: 30

    [simovsky@alpha ~]$
    Last edited by hurd; December 22nd, 2001 at 09:27 AM.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2001
    Posts
    6
    Rep Power
    0
    I think I found out the problem, but I don't know how to solve it, I think it's because other hosts (other than localhost) don't have permission to access my machine, because true localhost I can connect with ssh and other users can't, I changed hosts.allow in /etc, I add a line: ALL:ALL but everything seems to be in the same way.

    Hope you can help me,

    Best regards,
    Simao Mata
  10. #6
  11. Advisor
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Location
    Stockholm, Sweden
    Posts
    446
    Rep Power
    15
    You say you can access your local web from localhost...
    So..
    telnet localhost 80
    should be OK..

    But can you access your web via your real IP?
    try...with telnet on port 80
    telnet xxx.xxx.xxx.xxx 80

    or
    http://xxx.xxx.xxx.xxx/
    Does this work too?
    - [ If I cant fix it, ask MacGyver... ] -

IMN logo majestic logo threadwatch logo seochat tools logo