#1
  1. T-Shirt Tragic
    Devshed Novice (500 - 999 posts)

    Join Date
    Mar 2001
    Location
    Melbourne, Australia
    Posts
    886
    Rep Power
    321

    upgraded kernel.. now screen freezes.


    Hi all,
    Anyone know why kde would freeze up after I upgraded the kernel ...
    I was using 2.2.16 and upgraded to 2.4.2-11 now I only get about 4 minutes in kde and the system freezes completely forcing me to reboot. I can still boot into the old kernel.

    I'm using Suse ppc on a G3 mac...

    cheers.
  2. #2
  3. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14
    Have you tried staying in console mode for a while? (I believe that's what SuSE calls the shell, rather than X+KDE). It might be a kernel-KDE error, or it might be a general kernel problem, or it might be a kernel-X problem. Try different set-ups to see if it freezes.

    Once you know what's causing the problem, go for another kernel recompile and double check the sections that might affect the problematic area. If it's KDE, you might want to try recompiling KDE after you do a kernel compile.

    It's a bit difficult to say what's wrong without much info, sorry.
  4. #3
  5. No Profile Picture
    SourceSkipper
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2001
    Location
    Atlanta, GA.
    Posts
    1
    Rep Power
    0

    Post


    disable cron
  6. #4
  7. T-Shirt Tragic
    Devshed Novice (500 - 999 posts)

    Join Date
    Mar 2001
    Location
    Melbourne, Australia
    Posts
    886
    Rep Power
    321
    thanks guys for replying,
    I'm afraid I'm going to have to ask you both how to carry out your suggestions..

    How would I disable cron?

    Suse boots me into a graphic login.. on login it automatically drops me into kde, there doesn't seem to be any option to just login to console. Is there a boot parameter I can use to avoid logging in to kde?

    thanks again.
  8. #5
  9. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14
    When you get to the login screen, there should be an option to do with "console mode"?

    If not, then both that and cron are to do with your startup scripts. Now I'm not sure about this with SuSE, because of Yast... so I'd reccomend you first go into Yast and there's section where you ca nedit your rc.config file...

    have a look through there to see if you can change your default runlevel from 5 (X) to (at a guess, but it should tell you) 4 (console). GNU/Linux works by runlevels... 1 and 6 are for botting up and shutting down, 2 starts up services, 3, 4 and 5 are variations on console and X.

    Also look for services/daemons there (programs which run on startup and continue running in the background). See if "cron" (a task scheduler) is there, and if it is disable it.

    If you can't find either of those in Yast, then go into /etc and find a file called "inittab" which controls the runlevels and make necessary adjustments, and look for other files/directories with "rc" in them within /etc (I'm sorry but eveyr distro uses it's own rc structure so that's as helpful as I can be!).
  10. #6
  11. Wiking
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Sep 2000
    Location
    Sweden
    Posts
    3,608
    Rep Power
    27
    And if you don't want to get your hands dirty with config files, there is some option in YAST or YAST2 that lets you select which runlevel you wish to boot into (ie X, console etc). I think it's called graphical login, text login or something similar.

    You could also try SuSE's knowledge base, as there's plenty of information to be found there.

    //NoXcuz
    UN*X is sexy!
    who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; umount; sleep
  12. #7
  13. T-Shirt Tragic
    Devshed Novice (500 - 999 posts)

    Join Date
    Mar 2001
    Location
    Melbourne, Australia
    Posts
    886
    Rep Power
    321
    OK peoples ... thanks for the replies 'n all.
    A guy from Suse responded to my queries on the suse mailing list .. he says the problem has something to do with the sound on my g3 and that I should try a newer kernel, like 2.4.16 instead.. which I'm currently in the process of doing .. (have to update modutils.rpm as well.. this is causing dependency errors).

    If the Suse idea doesnt' work I'll try out everything that's been posted here.

    thanks again.
  14. #8
  15. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14
    Even if the SuSE idea does work, it'd still be worth you trying out the things suggested in this thread. Honestly the worst thing you can do with a nice 'n' easy distro is to sit back and pretend it's windows (i.e. use Star Office, browse the web a bit, download the occasional bit of software etc.) Which obviously you're not doing what with kernel upgrades, but still

    Tinkering, learning about the internals, will make your GNU/Linux experience that much more fun and rewarding.

IMN logo majestic logo threadwatch logo seochat tools logo