#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2001
    Location
    USA
    Posts
    194
    Rep Power
    15

    Socket connected. Waiting for welcome message.. then connection times out


    Hello,

    I have a 1.0 ghz processor, 512mb ram, Redhat linux 7.2, wuftpd 2.6.1-18. behind a linksys. I have been running months without a problem.

    Today, when I tried to connect through ftp using "cuteftp" . I can connect to my ftp site via "name", "external ip" or internal ip 192.168.1.101. I get the following message then it times out


    Socket connected. Waiting for welcome message.

    If I ftp in on the linux box itself it takes forever.

    I can't understand how it went to "h" in a handbasket overnight.



    in addition to this problem, My webserver seems to be running slow. connecting to my web site via "name", "external ip" or internal ip 192.168.1.101. it takes forever to bring up a webpage. If on the linux box it is fast "normal". also, if I telnet in, it takes long to get the user loggin screen.


    Any suggestions? Rebooting did nothing


    Thanks jobesd.
    Last edited by jobesd; February 19th, 2002 at 02:10 PM.
    I only do what the voices in my head keep telling me to do.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    start "top" on your linux system. it shows all processes and system resources usage.
    there could be a dead process consuming 100% cpu power.

    if you setup DNS wrong, this can occur too (also for the connection to the IP since both protocols try to determine the host name from the IP for logging and other issues).

    If on the linux box it is fast "normal".
    probably the DNS setup since local connections time out much faster than remote ones...
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2001
    Location
    USA
    Posts
    194
    Rep Power
    15
    my system resources are fine.

    cpu = 1 - 2%

    memory = used ram 10%


    My DNS settings on the box never change. They are the same.


    Is there a way to test the DNS server?

    my DNS servers are

    PRIM: 207.69.188.185
    SEC: 207.69.188.186
    TER: 207.69.188.187

    thanks jobesd
    I only do what the voices in my head keep telling me to do.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    sorry, i was talking about your local DNS, not the forwarding servers on the ´web

    the DNS servers on the web don´t know about 192.168.1.101!!! but they probably will be asked about it every time you access the IP.


    what do your /etc/hosts and /etc/resolv.conf look like?

    you can test your DNS using "nslookup".
    use it as "nslookup" and then on the prompt enter "set q=any" and then your ip or dns-name. does the query take just as long as the logins? (yes, they will )
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2001
    Location
    USA
    Posts
    194
    Rep Power
    15
    I would like to add that I have a cable modem, a dynamic ip and use a service from changeip.com. I never had a problem before so why now?

    resolv.conf

    search localdomain
    nameserver 207.69.188.185
    nameserver 207.69.188.186
    nameserver 207.69.188.187


    nslookup

    fast - very fast
    Last edited by jobesd; February 19th, 2002 at 02:34 PM.
    I only do what the voices in my head keep telling me to do.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    is nslookup as fast for entering your IP?

    can i have a look at your /etc/hosts and /etc/networks, plz?

    maybe your dynamic ip provider has changed configuration - a scenario i can think of:
    before:
    192.168.1.* was used internally and access was granted from anywhere
    now they restricted acces to local subnet for security reasons.

    so a query to 192.168.1.101 will be denied or even worse: be delayed for avoiding DOS attacks.

    your /etc/hosts is important to this, i think.
    you search .localdomain first, but who serves this? noone? then the servers up to the root-nameservers might be asked!
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2001
    Location
    USA
    Posts
    194
    Rep Power
    15
    hosts

    127.0.0.1 localhost.localdomain. localhost
    192.168.1.101 www.myfirstdomain.com myfirstdomain.com
    192.168.1.101 www.mysecdomain.com mysecdomain.com
    192.168.1.101 www.mythirddomain.com mythirddomain.com


    I don't show a /etc/networks file is it located somplace else
    I only do what the voices in my head keep telling me to do.
  14. #8
  15. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    the /etc/hosts was more important anyway.

    your setup is wrong i think. you should not define alternative host names in one line but in several ones.
    the syntax you use is for using long/short names (i think from knowing the basics behind)

    it should be:

    127.0.0.1 localhost.localdomain. localhost
    192.168.1.101 www.myfirstdomain.com www
    192.168.1.101 www.mysecdomain.com www2
    192.168.1.101 www.mythirddomain.com www3

    or something alike.

    i solved most problems like your one by setting up a local DNS server that forwards also anything to the web that is not known. especially if win**** machines are around.
    then you have:
    /etc/hosts
    127.0.0.1 localhost.localdomain localhost

    /etc/resolv.conf
    search localdomain
    nameservers 127.0.0.1

    and the DNS server does the rest.
    sorry if i am misleading you, this might not be worth it if your problem is not in this part of the OS....

IMN logo majestic logo threadwatch logo seochat tools logo