#1
  1. Ole` Timer
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2000
    Location
    N.W. Iowa
    Posts
    472
    Rep Power
    14

    Annoying Problem showing "dot" files


    Sorry if this is the wrong forum to post too, but wasn't sure where else to post it

    We're running on a RH/Linux 6.2 and this has been driving me nuts. I've looked thru the Apache conf files, ProFTPd conf file and can't find what prevents hidden or "dot" files from being displayed when an account FTP's into their account. In the apache httpd.conf, there is a setting to prevent display dot files within the browser, but this should prevent display the dot files, when FTP'ing into the account.

    I've tried various FTP client programs, and set it up to show hidden or "dot" files, but yet I can't get it to display the .htaccess or .htpasswd files. So some where I'm missing where this setting is. It's not a big problem, just an annoying problem as many clients get all flustered when they can't find their files, even tho they are there, just can't been seen.

    One thing I did notice, if Log in as "root" , then they are visiable, otherwise not. So there must be something configured on server to allowing viewing of the hidden/"dot" files only to "root"... but where, I just can't seem to find it.

    Any help would be much appreciated.

    Mickalo

    Thunder Rain Internet Publishing

    Custom Programming & Database development
    Providing Personal/Business
    Internet Solutions that work!
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    first to your login issue: root has another setup for the environment variable "LSOPTIONS". thatīs why.

    anyone can list them with ls -a (not sure about the a parameter though. do ls --help for further infos)

    you need to setup your ftp server not to serve file that start with a dot.

    which one are you using? (try "ftp localhost". it tells you the name - if it is not "hidden" by configuration)
  4. #3
  5. Ole` Timer
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2000
    Location
    N.W. Iowa
    Posts
    472
    Rep Power
    14
    Originally posted by M.Hirsch
    first to your login issue: root has another setup for the environment variable "LSOPTIONS". thatīs why.

    anyone can list them with ls -a (not sure about the a parameter though. do ls --help for further infos)

    you need to setup your ftp server not to serve file that start with a dot.

    which one are you using? (try "ftp localhost". it tells you the name - if it is not "hidden" by configuration)
    I'm using ProFTPD 1.2.4 Server.

    I want to be able to show the .htaccess or .htpasswd files when a user FTP into their account. There's nothing in the proftpd.conf file, that I can see that prevents this.

    Is there something that needs to be added to the conf file in order to allow displaying the .htaccess and .htpasswd files??

    thanks,

    Mickalo

    Thunder Rain Internet Publishing

    Custom Programming & Database development
    Providing Personal/Business
    Internet Solutions that work!
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    i am not an apache pro, but i think it is:
    <location */.ht*>
    deny from all
    </location>

    the apache manual will tell you how to do it exactly.

    here is the proftp thing (from the FAQ that comes with my proftp 1.2.0 distro - yours should be more up-to-date):

    use the IgnoreHidden directive inside a <Limit> block for one or more commands that you want to completely ignore the hidden directory entries
    so you need to remove this from your config...
  8. #5
  9. Ole` Timer
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2000
    Location
    N.W. Iowa
    Posts
    472
    Rep Power
    14
    use the IgnoreHidden directive inside a <Limit> block for one or more commands that you
    want to completely ignore the hidden directory entries

    so you need to remove this from your config...
    There is no directive in the proftpd.conf file regarding IgnoreHidden that I could find.

    Is there a URL to this FAQ's for Proftpd that you can supply??

    thanks,

    Mickalo

    Thunder Rain Internet Publishing

    Custom Programming & Database development
    Providing Personal/Business
    Internet Solutions that work!
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    190
    on your ftp server:

    file:///usr/share/doc/packages/proftpd/FAQ-config.html

    adjust the /share/doc to your local documentation directory.

    donīt know of a www url, but it should be on the proftpd homepage in the category "FAQ"

IMN logo majestic logo threadwatch logo seochat tools logo