Page 1 of 2 12 Last
  • Jump to page:
    #1
  1. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Jul 2001
    Location
    In a constant state of turmoil
    Posts
    858
    Rep Power
    83

    Help installing drivers


    Hi

    I'm totally new to Linux, but I'm trying to learn it from the command line. So far it feels about like I would assume it feels trying to steer a submarine, they can't look out the "Windows" to see where their going either. ;-)

    Any way, I have Red Hat 7.1 installed and running fine except for the fact that the install didn't automatically recognize my nic card (which is on the Red Hat compatibility list) and did not install the drivers. The floppy that came with the card has instructions for installing the driver on RH 5.2 and it seems the directory structure as well as a few other things have changed between 5.2 and 7.1, so these instructions are of no help to a newbie.

    I have visited the "Network Driver Updates Page" and I don't really understand the instructions they give to install the update. I don't have internet access on my Linux box yet so I can't do the ftp thing that they mention, and I'm not fluent enough in *nix speak yet to know what to do unless the instructions are kinda precise. I have downloaded the src.rpm file and put it on a floppy.

    So you don't have to follow the link above (unless you want to) I've included the instructions from that link at the end of this post. I would be very grateful to anyone who could take me from the point where I put the floppy in my Linux box thru the installation, and please don't assume I know how to do anything with Linux.

    Thank you very much, and here's the instructions mentioned above.

    Using the Source RPM Package
    The updated drivers are best installed by using the source RPM to create a custom binary RPM with kernel modules for your system:
    ftp://ftp.scyld.com/pub/network/netd...-3.1-1.src.rpm

    Use the following commands to install and test the driver pack:

    # Transfer the Scyld PCI Netdriver package
    # Perhaps use ncftpget ftp://ftp.scyld.com/pub/network/netd...-3.1-1.src.rpm
    rpm -i ftp://ftp.scyld.com/pub/network/netd...-3.1-1.src.rpm
    # Build the binary version for your kernel
    cd /usr/src/{redhat,TurboLinux,packages}/
    rpm -bb SPECS/netdriver*.spec
    # Now install it your newly built package.
    rpm -i --force RPMS/i386/netdrivers-3.1-1.i386.rpm
    The --force option is needed because the new drivers may conflict with the existing drivers installed by the kernel package. If this occurs you will see a warning message for each driver that has been updated.
    Thanks again
    ~Butcher~
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191
    when you are logged in as root, do this:

    1. copy the file to your haddisk for faster access:
    mount /dev/fd0 /mnt
    cp /mnt/* .
    umount /mnt
    2. install the file not from ftp but locally:
    rpm -i <filename.src.rpm>
    3. then go on compiling the sources.

    i doubt you´ll succeed this way and i doubt you´ll have fun with this type of setup. you better find out how to make the nic work with redhat´s own drivers.

    much luck!
  4. #3
  5. Wacky hack
    Devshed Novice (500 - 999 posts)

    Join Date
    Apr 2001
    Location
    London, England
    Posts
    513
    Rep Power
    14
    The RPM you have is a source RPM, which means you have to build it into a binary RPM before you install it, which is a step M.Hirsch missed out. To build source RPMs, you stick them in a directory called something like /usr/src/packages/SPECS (for drivers) and /usr/src/packages/SOURCES (for applications), and then you run rpm telling it to build an binary rpm from the source rpm. Once it has done that, you can install the binary RPM. So you need to do the following:

    1. Copy the file to your haddisk for faster access. redHat may have already set-up a way of accessing your floppy, but if not, you can do it manually like so:
    mount /dev/fd0 /mnt
    cp /mnt/* .
    umount /mnt

    2. Move the source rpm into the correct directory... so hunt around /usr/src for something like "packages/SPECS" or perhaps "rpm/SPECS", and when you've found a suitable place, move the rpm to that location.

    3. Build the source RPM into a binary rpm, like so:
    rpm -bb SPECS/netdriver*.spec
    Now I'm not certain, not having used src RPMs, but that might mean type that exact command whilst in "/usr/src", or it might mean type "i386" where it says "spec" at the end... the rpm manpage is a touch unclear. Try both, see which works.

    4. Once you've built the source RPM into a binary RPM, check it's in the right place, so look for "/usr/src/RPMS/i386/netdrivers-3.1-1.i386.rpm ". If it's not there, you need to try step3 again, until it does work.

    5. Install the binary rpm whilst in /usr/src:
    rpm -ivh --force RPMS/i386/netdrivers-3.1-1.i386.rpm
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Jul 2001
    Location
    In a constant state of turmoil
    Posts
    858
    Rep Power
    83
    Thanks guys, you were both right.

    telex4

    I was able to fiddle around with the directions you gave me and managed to get to the point where I was trying to make the binary. When I ran the command, a whole crapload of text went flying by on my screen, and most of it seemed to be warnings and errors. Needless to say, It didn't make the binary, so I could go no further.

    M.Hirsch

    You were right when you said:

    i doubt you´ll succeed this way and i doubt you´ll have fun with this type of setup.
    Now... Could anybody either tell me how to get RedHat to recognize my nic at boot up and install the right drivers? I'll even reinstall it if that's what it takes, but the network configuration screen doesn't show up when I install because it isn't recognizing it.

    If not that, then can someone translate these instructions from the Netgear driver disk so that I could try and do this on version 7.1. I've tried it myself by copying the files to my /root folder and then trying to execute the command cctulip but it tells me that command does not exist.

    ----------------

    With either the adapter cards based on the DEC 21140 controller (versions
    C1, C2 or C6) or the new NETGEAR cards (revisions D1, D2 or D3), the
    "Digital 21040 (Tulip)" driver included in the software can be used.
    With C1, C2 or C6, the RedHat installation software automatically detects
    and points to the proper driver. With revisions D1, D2, or D3, you
    must manually instruct Linux to use the "Digital 21040 (Tulip)" driver
    under the "Which card to support" network window.

    However, the Tulip driver (version 0.89H) included in RedHat Linux 5.2
    configures the transmit threshold of the revisions D1, D2, and D3 cards
    to Store-and-forward. To improve the network performance of the adapter
    card under Linux, it is recommended you use the Linux driver provided
    in the floppy (version 0.89K) or the latest Tulip driver (0.90Q) down-
    loadable from the following web site:

    http://cesdis.gsfc.nasa.gov/linux/drivers/tulip.html


    Installation Procedure for Modular Kernel
    -----------------------------------------

    1. During installation of Linux, make sure that the "C Development"
    selection is choosen under "Component to Install" window. This will
    copy the C compiler into the system for compiling the driver.

    2. Also the Network Configuration window during installation, you will
    be asked if you want to configure LAN (not dailup) networking for
    your installed system. Answer YES.

    3. Insert the floppy disk with the FA310 driver, and mount the disk into
    the system with the following command:

    mount -t msdos /dev/fd0 /mnt

    4. Copy the Linux-related files from the disk into the system hard disk
    with the following command. Four files will be copies: "cctulip",
    "tulip.c", "Copying", and "linux.txt".

    cp /mnt/linux/*.* .

    5. Compile tulip.c by executing the "cctulip" command at the prompt.
    The following command will be executed.

    gcc -DMODULE -D__KERNEL__ -I/usr/src/linux/net/inet -Wall -Wstrict-prototypes -O6 -c tulip.c

    6. Find the names of the files in the /lib/modules directory. You
    might see the following directories.

    eg. "2.0.36-0.7" and "preferred".

    7. Copy the newly compiled tulip.o into the latest kernel's modules.

    cp tulip.o /lib/modules/2.0.36-0.7/net/tulip.o

    8. Reboot the system.

    9. You can check if the driver is properly activating the card using
    the "dmesg" command right after system bootup.

    -------------

    If anyone has any other suggestions on how I can or should do this, please feel free.

    Thanks again for all your helps to this point.
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191
    this way seems much easier to me.

    to help you, we need more information:
    - which revision of the NIC do you have? (you should find this on the NIC´s board or biggest chip)
    - which kernel version do you use ("uname -a")
    - did you find the tulip driver in the redhat setup?
    - did you try these instructions and what and where failed?

    Furthermore:
    when logged in as root, you must prepend "./" (i.e. "./cctulip") to commands in your working dir. unlike windows it does not automatically execute commands in the current directory!
  10. #6
  11. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    111

    also strugging, but here's what I know


    I am having pretty much the same problems. I know this is a long post, but if we bring together everything we are trying, then hopefully we will work it out! If you would rather I start this as a new thread, say so, but I think we're aiming for the same thing here... I am trying to configure an ethernet adaptor to connect to my ADSL router. This is the first my system has seen of any network activity - also a bit of new territory for me aswell !
    I am using an Asus Hi-Grade UltiNote AS8400 laptop, with build in ethernet. Running Red Hat 7.2, with a 2.4.7-10 kernel

    A Google search suggested that I would need the 'rtl8139.o' module to go with my card. Can anyone expand on this? here's the toast:

    To start with, I get a description of my ethernet adaptor:

    $cat /proc/pci

    Bus 0, device 8, function 0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 16).
    Master Capable. Latency=64. Min Gnt=32.Max Lat=64.
    I/O at 0xf000 [0xf0ff].
    Non-prefetchable 32 bit memory at 0xfedffc00 [0xfedffcff].

    I then try running 'neat' to initialise a new eth0 device. The fields in the GUI screen are a bit cryptic, but I can at least get the right model. WHen I probe the interface in Windoze, I'm told it has an IRQ level 9, so I am entering this into the 'neat' screen - is that right? and what could be the required values for:
    MEM: IO: IO1: IO2: DMA0: DMA1: ?? I can never get past this stage and I always get the warning: 'The Ethernet card could not be initialized. Please verify your settings and try again.'

    I then look in /etc/modules.conf and /proc/modules

    $cat /etc/modules.conf

    reveals the following: (note: no sign if any ethernet module)

    alias parport_lowlevel parport_pc
    alias sound-slot-0 maestro3
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

    $/sbin/lsmod

    gives this: (note no rtl8139 module listed)

    Module Size Used by
    ppp_deflate 41376 0 (autoclean)
    bsd_comp 4384 0 (autoclean)
    ppp_async 6736 0 (autoclean)
    ppp_generic 19296 0 (autoclean) [ppp_deflate bsd_comp ppp_async]
    .
    . bla bla
    appletalk 20912 0 (autoclean)
    ipx 16448 0 (autoclean)
    ipchains 39200 0

    So the next sensible move might be to probe for the rtl8139 module:

    $/sbin/modprobe rtl8139.o
    modprobe: Can't locate module rtl819.o

    So I went out on the internet and downloaded the following files:
    rtl8139.c
    pci-scan.c
    pci-scan.h

    then off I go to find the right locations, but the paths are totally different on my system.
    In fact,
    /lib/modules/[kernel-version]/net/driver.o. isn't there. Any attempts to compile the module source fails, and I start wondering if there is a much simpler solution to all this!!?? I think that if we only knew what the Red Hat equivalent paths were, then we would know where to put these modules.

    as a last attempt, I tried the rpm route:
    [root@localhost]$ cd /usr/src/redhat/SPECS
    [root@localhost redhat]# rpm -bb SPECS/netdriver*.spec
    error: failed to stat /usr/src/redhat/SPECS/netdriver*.spec: No such file or directory
    [root@localhost redhat]# rpm -bb SPECS/netdriver*.i386
    error: failed to stat /usr/src/redhat/SPECS/netdriver*.i386: No such file or directory

    I hate life !

    later
    Christo

    ps I just pasted all this from my vi screen - hope it doesn't stuff up!
    This is me: http://chris.uk.com
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191
    try "modprobe rtl8139" without the ".o"

    same for butcher: "modprobe tulip"

    you don´t need to tell the irq or any settings to the driver since you are using a pci card.
  14. #8
  15. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    111
    [root@localhost chris]# /sbin/modprobe rtl8139
    modprobe: Can't locate module rtl8139


    I think I might try compiling the source files in the rpm location... er or something. Or maybe I should just go to the pub and sulk!
    This is me: http://chris.uk.com
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191
    linux:~ # ls -l /lib/modules
    drwxr-xr-x 3 root root 4096 Feb 3 22:12 .
    drwxr-xr-x 6 root root 4096 Feb 3 22:49 ..
    drwxr-xr-x 15 root root 4096 Feb 3 22:24 2.2.18

    linux:~ # find /lib/modules/ -name rtl8139*
    /lib/modules/2.2.18/net/rtl8139.o
    linux:~ #
    maybe you need to install it from your distro´s cdroms...
  18. #10
  19. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    111
    hmmm. I even tried:

    $ cd /lib
    $ find . -name rtl*

    and nowt !
    I'll go have a look in the CD's
    No word from Butcher. I wonder how he's getting on!

    Thanks Manuel (sp?)
    This is me: http://chris.uk.com
  20. #11
  21. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    111
    nothing on distro cds I'm going to try again to compile the libraries myself.. although it wouldn't let me do it earlier.. can't remember why, but I think it was a missing paths issue.
    Back later!
    This is me: http://chris.uk.com
  22. #12
  23. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Jul 2001
    Location
    In a constant state of turmoil
    Posts
    858
    Rep Power
    83
    Okay

    I've run "modprobe tulip" and got the following:

    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: init_module: No such device
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: insmod /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o failed
    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: insmod tulip failed



    In reading over CHR15T0's posts I tried some of the commands he was testing and I'll list the results in case it will help.

    when I ran "cat /proc/pci" there was no lising for an ethernet card

    but, when I run "cat /etc/modules.conf" I get this:

    alias parport_lowlevel parport_pc
    alias usb-controller usb-uhci
    alias eth0 tulip


    when I ran "/sbin/lsmod" I got this for my efforts:


    Module Size Used by
    autofs 11136 1 (autoclean)
    ipchains 38944 0 (unused)
    usb-uhci 20848 0 (unused)
    usbcore 49632 1 (usb-uhci)



    Like CHR15T0 said, it seems that anything I come across that looks like it will work, has the wrong paths built into it to work on my distro of Linux.

    Thanks for all the help and support guys
  24. #13
  25. Introspective
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    3,317
    Rep Power
    111
    Butcher,

    even if you get the module source compiled and the binary installed, you might still have problems, because your system isn't smelling the hardware. I mean when you $cat /proc/pci , you should be able to see your hardware there, even if you don't have the right drivers to use it. So doesn't that mean that once your driver modules are all in place, you still won't be able to use the NCI, cos it ain't smelling right!

    I'm not sure, but I guess this would be the case

    ?!?!?

    Christo

    I tried compiling again last night, just to be told that I'm using the wrong headers and that I should be using package-specific headers, NOT kernel headers. I'm at work right now, so I'll post this evening with the toast...
    This is me: http://chris.uk.com
  26. #14
  27. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191
    Hi Butcher!
    To clarify some things:
    I've run "modprobe tulip" and got the following:
    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: init_module: No such device
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: insmod /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o failed
    /lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o: insmod tulip failed
    since modprobe seems to "know" the path to tulip.o, the file seems to be there -> the second reason told applies ("...caused by incorrect module parameters").
    when I ran "cat /proc/pci" there was no lising for an ethernet card
    afaik the tulip driver is pci only. is your card a pci card? (or onboard which is the same for 99%)
    if it is not listed here, there is some kind of big problem
    does it work on windows?
    but, when I run "cat /etc/modules.conf" I get this:

    alias parport_lowlevel parport_pc
    alias usb-controller usb-uhci
    alias eth0 tulip
    is this the complete file? then the parameters are fine (none).
    if there is a line like:
    options tulip io=0x300 irq=10
    then, unless you really have an ISA card, remove it.
    when I ran "/sbin/lsmod" I got this for my efforts:
    Module Size Used by
    autofs 11136 1 (autoclean)
    ipchains 38944 0 (unused)
    usb-uhci 20848 0 (unused)
    usbcore 49632 1 (usb-uhci)
    fine. the module is not loaded. (not so fine, but expected since you could not load it ... )
    Like CHR15T0 said, it seems that anything I come across that looks like it will work, has the wrong paths built into it to work on my distro of Linux.
    ch15t0s problem was only in compiling a driver from source... i don´t think it could be related to what you tried...

    so, final word:
    is your card pci? who is the manufacturer?
    what is the exact inscription on the largest chip on your nic board (maybe also the second largest)?
    and does it tell any other clues about a possible type number, name or something like this? maybe you have a different chipset than you think...

    like eg. i bet more than 30% of nics sold today are equipped with Realtek 8139 chipset (at least here in germany)...

    and another thing to try: "depmod -av" - does it output any errors? (like missing dependencies?)
    Last edited by M.Hirsch; May 13th, 2002 at 01:14 PM.
  28. #15
  29. No Profile Picture
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2002
    Location
    The Emerald City
    Posts
    289
    Rep Power
    13
    The tulip driver has a 'debug' option that you can set to print (or log, perhaps) more volumeous output. You can set it from 0 (no debugging) to 6 (wordy). The relevant lines in the modules.conf file would look like:

    alias eth0 tulip
    options tulip debug=1

    I had similar trouble with my tulip module in the past but i can't remember how (or if) I fixed it as a module. Now I just have it compiled into the kernel.
Page 1 of 2 12 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo