1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2002
    Rep Power

    Apache configuration

    Hi guys, I am a Linux newbie, and I have 4 questions ..
    Which of you guru's can help me?

    I run Linux Mandrake 8.1 and I have installed ALL modules etc.
    The complete install!

    Problem: #1
    I want to have complete acces over my files from a Windows computer in my LAN.
    I have Webmin, and Samba, but I can't get it to work ...

    Problem: #2
    I run apache because I am testing my beta website.
    It's using alot of PHP and MySQL, and there is one thing I can't manage to fix.
    Uploading a file. I don't have the permission to do that.
    I know the script is good .. used it before on my windowsPC...

    I get this message:
    PHP Code:
    WarningUnable to create '../swf-files/dieptes.swf'Permission denied in /var/www/html/php-files/processuploads.php on line 40 
    Problem: #3
    I have always used phpMyAdmin to manage my databases .
    I can't get this program to work anymore ... Do I need to installer something adittional ???

    Problem: #4
    I use Webmin to manage most configs.
    When I want to edit or set the SENDMAIL ... it gives the error sendmail.cf cannot be found .. I can't find anything about this topic .. What do I need to do?

    Thanks in advance ya'll
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Back in the real world.
    Rep Power
    Hi! Welcome to the Linux community

    as usual, i first suggest you buy a book and / or linux magazines. how long did it take you to learn windows and how many people could you ask at this time?

    Problem: #1
    Webmin is a afaik total security fīup. If you want to connect to the internet, deinstall it!
    for samba: samba comes with its own, easy-to-use gui (web-based like webmin): SWAT. edit /etc/inetd.conf, look for a line similar to "# swat swat - ....... - /usr/local/samba/bin/swat". remove the comment-sign ("#"), restart inetd ("killall -HUP inetd" on the console) and then access it with "http://<your-ip>:901"
    read on. in a later problem, iīll discuss the problems with complete access to all your linux files...

    Problem: #2
    Yes, this is where i add on to the last sentence.
    Linux has a different permissions scheme than windows. on windows 9x/me you donīt have file permissions at all. anyone can edit/modify/delete all files, his own, othersī and system files.
    on windows NT/2k/XP, you have a (quite good and detailed) user/group permission scheme. you canīt delete other usersī data and you canīt delete system files. (unless you are the administrator)
    the latter is similar in linux. your files and folders have permissions (although they work a little different from windows...).
    you are nearly right: it is your web-server that is not allowed to write files anywhere
    short explanation:
    each file and folder has three groups of permissions: user-, group- and world-permissions. these can be a mixture of "read", "write", "execute". these are written in a row, eg:
    /home/user/myfile could have "rwxrwxr-x", that is: first three are user. he can read, modify and execute the file (any file can be executable in unix, they donīt need stoopid names like ".com" or ".exe")
    middle three are the group (iīll leave group ownership out for now) and the last three are "world" which is anyone not being the user or in the fileīs group. they can only read and execute. no writing.
    your solution:
    the webserver usually runs as wwwrun/nogroup or similar. so you create the folder it should be allowed to write to as aministrator:
    login as root.
    cd /usr/local/www/ (or where ever your docroot is)
    mkdir upload
    chown wwwrun upload (change owner of "upload" to "wwwrun")

    then you have a folder where your server IS allowed to write to since it belongs to it

    Problem: #3
    phpMyAdmin is cool. i use it too.
    if it is installed, first look where. is it /usr/local/www/phpMyAdmin or does it have a different name. something like "rpm -q -l phpmyadmin" or "find /usr -name phpMyAdmin*" could give a hint. your installation program should support listing the files in rpms too.
    you only need a web server with php support. php support must be enabled for the extension of the phpMyAdmin files. they come in two variations: one always ends in .php3, one always .php . but mandrake should have taken care of this for you...

    Problem: #4
    Sorry, canīt help you much here. Sendmail is very complicated and i never dealt with mandrake before...

    Long post, eh? hope this helps and thus was worth the effort!
    Last edited by M.Hirsch; June 4th, 2002 at 02:29 PM.

IMN logo majestic logo threadwatch logo seochat tools logo