#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Location
    istanbul
    Posts
    108
    Rep Power
    0

    Php5.2 to 5.3 upgrade problem for debian lenny


    Using debian lenny;

    2 months ago added my /etc/apt/sources.list
    file

    deb http://php53.dotdeb.org oldstable all
    deb-src http://php53.dotdeb.org oldstable all

    those lines and
    run
    apt-get update
    apt-get dist-upgrade

    and upgraded my php5.2 to 5.3

    and yesterday somehow it turned 5.2(thats not the question)
    now i try to upgrade it again but got this result

    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Recently they put 5.4 packets for squeeze on http://php53.dotdeb.org it would be the reason for this?

    cos i totally deleted all php-related packets and reinstalled them but nothing changed(with configuration files and also without counfiguration files) now i think http://php53.dotdeb.org is the problem.

    thx.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Location
    istanbul
    Posts
    108
    Rep Power
    0
    are those the expectede responses?

    server:~# apt-get update
    Hit http://php53.dotdeb.org oldstable Release.gpg
    Ign http://php53.dotdeb.org oldstable/all Translation-en_US
    Hit http://php53.dotdeb.org oldstable Release
    Ign http://php53.dotdeb.org oldstable/all Packages/DiffIndex
    Ign http://php53.dotdeb.org oldstable/all Sources/DiffIndex
    Hit http://php53.dotdeb.org oldstable/all Packages
    Hit http://php53.dotdeb.org oldstable/all Sources
    Reading package lists... Done

    may be cant get the packeges?
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    0

    Same problem here...


    I'm having exactly the same problem here:
    It looks like the repository structure at dotdeb for Lenny does not contain any packages

    Maybe an unnoticed regression?
    The package files for PHP 5.3.x actually do exist - but only on "archives.dotdeb.org" (which can't be used as apt-source, because it has no proper repository structure)

    The best thing is to talk to the dotdeb maintainers to check if it's on purpose or not.

    (Sorry, could not post URLs due to forum restrictions. Thanks spammers!)

IMN logo majestic logo threadwatch logo seochat tools logo