#1
  1. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jun 2003
    Location
    Thessaloniki
    Posts
    1,402
    Rep Power
    0

    Fail when tryign to install libmaxminddb


    https://github.com/maxmind/libmaxminddb

    Code:
    root@secure [~/libmaxminddb]# ll
    total 108
    drwxr-xr-x 11 root root  4096 Oct 26 10:16 ./
    dr-xr-x--- 22 root root  4096 Oct 26 12:02 ../
    drwxr-xr-x  8 root root  4096 Oct 26 10:16 .git/
    -rw-r--r--  1 root root   271 Oct 26 10:16 .gitignore
    -rw-r--r--  1 root root    91 Oct 26 10:16 .gitmodules
    -rw-r--r--  1 root root   233 Oct 26 10:16 .travis.yml
    -rw-r--r--  1 root root  3336 Oct 26 10:16 .uncrustify.cfg
    -rw-r--r--  1 root root     0 Oct 26 10:16 AUTHORS
    -rw-r--r--  1 root root     0 Oct 26 10:16 ChangeLog
    -rw-r--r--  1 root root 26530 Oct 26 10:16 LICENSE
    -rw-r--r--  1 root root   106 Oct 26 10:16 Makefile.am
    -rw-r--r--  1 root root  3049 Oct 26 10:16 README.md
    drwxr-xr-x  2 root root  4096 Oct 26 10:17 autom4te.cache/
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 bin/
    -rwxr-xr-x  1 root root   426 Oct 26 10:16 bootstrap*
    -rw-r--r--  1 root root   107 Oct 26 10:16 common.mk
    -rw-r--r--  1 root root  3452 Oct 26 10:16 configure.ac
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 dev-bin/
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 doc/
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 include/
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 maxmind-db/
    drwxr-xr-x  2 root root  4096 Oct 26 10:16 src/
    drwxr-xr-x  3 root root  4096 Oct 26 10:16 t/
    root@secure [~/libmaxminddb]# boostrap
    -bash: boostrap: command not found
    root@secure [~/libmaxminddb]# ./bootstrap
    rm: cannot remove `ltmain.sh': No such file or directory
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal --force 
    configure.ac:4: error: Autoconf version 2.65 or higher is required
    configure.ac:4: the top level
    autom4te: /usr/bin/m4 failed with exit status: 63
    aclocal: autom4te failed with exit status: 63
    autoreconf: aclocal failed with exit status: 63
    root@secure [~/libmaxminddb]#
    Whay cant i just install libmaxminddb?
    I downloaded try to

    ./bootstrap
    ./configure

    but it fails.
    Last edited by Nik; October 26th, 2013 at 04:07 AM.
  2. #2
  3. Contributed User
    Devshed Specialist (4000 - 4499 posts)

    Join Date
    Jun 2005
    Posts
    4,482
    Rep Power
    1875
    > configure.ac:4: error: Autoconf version 2.65 or higher is required
    It would seem you need a newer version of autoconf
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper
  4. #3
  5. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jun 2003
    Location
    Thessaloniki
    Posts
    1,402
    Rep Power
    0
    Originally Posted by salem
    > configure.ac:4: error: Autoconf version 2.65 or higher is required
    It would seem you need a newer version of autoconf
    what exsctyl shoudl i use please?
    what i have to do to install it?
  6. #4
  7. Contributing User
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    Jun 2003
    Location
    Thessaloniki
    Posts
    1,402
    Rep Power
    0
    can you please tell me a way to install 'libmaxminddb' because my website depends on this module to grab geographical information based on visitor's ip address?

IMN logo majestic logo threadwatch logo seochat tools logo