#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Posts
    493
    Rep Power
    60

    change root password - single user mode -- OS X 10.3???


    hey everyone,
    has anyone heard about those 4 steps you can do in single user mode to change the root password??

    /sbin/fsck -y
    /sbin/mount -wu /
    /sbin/SystemStarter

    then passwd root

    i've tried it on my 10.2 machines, and it's worked great. however, when i tested it on my panther machine, all the steps worked fine, however when i typed passwd root, instead of asking me for a new password, it just returned a new line, ready for more commands.

    what's up with this??
  2. #2
  3. Hello World :)
    Devshed Frequenter (2500 - 2999 posts)

    Join Date
    Mar 2003
    Location
    Hull, UK
    Posts
    2,537
    Rep Power
    69
    I never had the chance to use OSX 10.2 so I'm not sure how much help I can be there not knowing what was changed but in Panther the root account is disabled by default and the password is set to '*'. This simply means that you can't change it, or at least not while the '*' is there .

    The simplest way to enable root is to use the NetInfo manager: click the padlock and enter your password so you can make changes if you need to and click Enable Root User under the Security menu.

    You should also be able to do this from the command line using the ni* commands however if you can I would use the manager .

    Hope this helps,

    Mark.
    programming language development: www.netytan.com Hula

  4. #3
  5. No Profile Picture
    Contributing User
    Devshed God 1st Plane (5500 - 5999 posts)

    Join Date
    Oct 2000
    Location
    Back in the real world.
    Posts
    5,966
    Rep Power
    191

    How to boot into single user mode with Mac OSX >= 10.3


    A bit late, but here's the solution.

    (assuming there is no protection enabled for open firmware)

    1. hold command-S when booting
    2. /sbin/fsck -y
    3. /sbin/mount -uw /
    4. /usr/libexec/register_mach_bootstrap_servers /etc/mach_init.d
    5. cd /var/db/netinfo; netinfod -s local
    6. /sbin/SystemStarter


    Steps 4/5 are new for Mac OSX 10.3

    HTH,
    M.

    Comments on this post

    • haid agrees : Way late repuation, but thanks for the help! :)

IMN logo majestic logo threadwatch logo seochat tools logo