#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2013
    Posts
    2
    Rep Power
    0

    Email disappeared on qmail server


    I'm beginning to be desperate regarding a mail that seems to have completely disappeared on my Ubuntu Linux 10.04 LTS 64 bit server running qmail+vpopmail. Every domain has a .qmail-default containing the following: /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox

    Furthermore the server has software RAID1 with 3 hard-drives.

    Here is what happened:

    May 8 at 8:59 user A sends a message to user B and C. A, B and C are all local mail users. a-local-domain, b-local-domain and c-local-domain are all hosted at my server (hence the names).

    2013-05-08 08:59:18.240881500 new msg 264573
    2013-05-08 08:59:18.240882500 info msg 264573: bytes 1641963 from <aATa-local-domain.com> qp 9051 uid 33
    2013-05-08 08:59:18.240899500 starting delivery 1570: msg 264573 to local b-local-domain.com-bATb-local-domain.com
    2013-05-08 08:59:18.240900500 status: local 1/10 remote 0/10
    2013-05-08 08:59:18.240901500 starting delivery 1571: msg 264573 to local c-local-domain.com-cATc-local-domain.com
    2013-05-08 08:59:18.240907500 status: local 2/10 remote 0/10
    2013-05-08 08:59:18.475726500 delivery 1571: success: did_0+0+1/
    2013-05-08 08:59:18.475750500 status: local 1/10 remote 0/10
    2013-05-08 08:59:19.210562500 delivery 1570: success: did_0+0+1/
    2013-05-08 08:59:19.210631500 status: local 0/10 remote 0/10
    2013-05-08 08:59:19.210669500 end msg 264573

    User C has confirmed that he received the message successfully. User B, however, claims never to have received the message. And I believe he is right:

    At May 8 08:30:05 user C logs in and checks his mail. He does not check mail until May 9 12:01:27. I see this in the mail.info log files.

    I have a daily back-up from May 9 04:30, and here the mail is not present! It should be here, because user C could not have deleted the message. The mail is totally local, no chance of spam-filter interference by SpamAssassin.

    And no: user C has not set up any mail forwarding - I've checked it myself.

    Where should I start digging? My server hardware, RAID, file system, qmail, vpopmail???

    Any help much appreciated!
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,445
    Rep Power
    4539
    Maybe use B has an overly-aggressive spam filter in their email program
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2013
    Posts
    2
    Rep Power
    0
    Originally Posted by Doug G
    Maybe use B has an overly-aggressive spam filter in their email program
    Thanks for your reply and suggestion Doug G. However, the email never reached user B's the email program. It simply disappeared on the server.

IMN logo majestic logo threadwatch logo seochat tools logo