#1
  1. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    187
    Rep Power
    11

    Port 110 not connecting


    [System]
    RedHat 9.0
    XMail 1.20 (Newest Version)

    [Problems]
    -Unable to connect to port 110 from outside the server

    [Details]
    I am able to telnet to port 110 from inside the server, but from outside the server port 110 timesout and i am unable to connect. I do not have a firewall on port 110.

    [Questions]
    1) Could there be a software conflict? Are there any programs installed on port 110 by default with RH9 that i dont know about?
    2) Is this an XMail configuration problem?
  2. #2
  3. Full Access
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jun 2000
    Location
    London, UK
    Posts
    2,019
    Rep Power
    16
    1) Could there be a software conflict? Are there any programs installed on port 110 by default with RH9 that i dont know about?
    No - only one program can listen on a port at any one time. Any subsequent attempts to listen on the same port will fail.

    Run
    Code:
    lsof -n -i:110
    on your machine to show what process is listening on port 110.
    2) Is this an XMail configuration problem?
    Possible, but unlikely. Since you can connect locally but not remotely, I suspect that either the POP3 server is not listening for remote connections (unlikely, as this kind of defeats the point of a POP3 server), or some kind of firewalling is going on that you're not aware of. Post the IP address of this machine, and I can verify whether or not this is the case.
    Alex
    (http://www.alex-greg.com)
  4. #3
  5. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    187
    Rep Power
    11
    Ahh, i did not know what was running on my own machine. the program "iptables" was running and it had port 110 blocked, so i could only access port 110 from inside the machine. Now everything is working like a charm :-D. For all of you out there that think you dont have a firewall, you may have one that is hidden from you !!
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2012
    Posts
    1
    Rep Power
    0

    Red face


    I am having the same problem with incoming pop port 110. There is no connection. I tried running the suggested code, but I just got a message that the code was not recognized.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2012
    Posts
    6
    Rep Power
    0
    Hello,

    If you are using Exim mail server then check if the 110 port it enabled in exim.conf file. Also give a check for server side firewall and make sure that port 110 is enabled.
    Last edited by hiker; September 15th, 2012 at 04:42 PM. Reason: Removed fake sig

IMN logo majestic logo threadwatch logo seochat tools logo