#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Location
    Australia
    Posts
    1
    Rep Power
    0

    Qmail open relay problem


    Hi,

    I'm running qmail 1.3 on RedHat 9, and today I noticed several return mail daemon messages in my inbox, and a check of the qmail logs showed that qmail appears to be relaying mail when the sender's address is blank (<>)! Here is a copy of a relevant section from my main qmail log:

    2004-01-27 15:08:36.950443500 new msg 917588
    2004-01-27 15:08:36.950448500 info msg 917588: bytes 32147 from <> qp 31300 uid 522
    2004-01-27 15:08:36.958682500 starting delivery 148: msg 917588 to remote bob@michaelpage.com.au
    2004-01-27 15:08:36.958858500 status: local 0/10 remote 1/20
    2004-01-27 15:08:43.883598500 delivery 148: success: 210.8.200.66_accepted_message./Remote_host_said:_250_2.0.0_Message_received_OK/
    2004-01-27 15:08:43.883619500 status: local 0/10 remote 0/20
    2004-01-27 15:08:43.883624500 end msg 917588

    Sorry if that doesn't wrap properly... it appears that q-mail relayed that message successfully! Can anyone help? I am suddenly receiving about a dozen return mail daemon e-mails per day now, whereas yesterday I had none... and qmail still passes all other open-relay tests (it only fails when the sender's e-mail address is blank).
  2. #2
  3. Full Access
    Devshed Regular (2000 - 2499 posts)

    Join Date
    Jun 2000
    Location
    London, UK
    Posts
    2,019
    Rep Power
    17
    a check of the qmail logs showed that qmail appears to be relaying mail when the sender's address is blank (<> )!
    These are bounce messages from qmail. If you look a bit further up in your log file you will see a message from bob@michaelpage.com.au trying to be delivered, and failing, hence the bounce.
    Alex
    (http://www.alex-greg.com)

IMN logo majestic logo threadwatch logo seochat tools logo