#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2000
    Location
    turkey
    Posts
    11
    Rep Power
    0

    Qmail does not send e-mail


    The qmail queue on my dedicated server is getting larger constantly. For the last 4 days or so, no e-mail is being delivered to the target server. The users are able to accomplish the send/reseive task on the mail reader without any problems. There does not seem to exist any problems about the incoming mail, either. They are delivered to the local mailboxes. But when people try to send e-mail from my server, it stays in the queue. The e-mails are either not delivered at all or delivered with one or two days delay. There are about 11000 emails in the queue. I have been following the queue since there were 2000 e-mails. Every other few hours, the queue has a few hundred more e-mails. I checked if any of the mailboxes exceeded quota. But none of them has this problem. So it is not about one mailbox making qmail slow down. When I check the queue, I founnd out that more than 40% of the e-mails are something about the postmaster. A sample data is as follows;

    11 Jun 2006 23:20:30 GMT #9192916 3627 <#@[]>
    remote postmaster@server.name.dom

    I would like to have the server become capable of send e-mails without problems ASAP. Any ideas about what the next step might be in order to get closer to the solution?
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2000
    Location
    turkey
    Posts
    11
    Rep Power
    0

    The error message


    Finally I do have an error message

    The emails sent returns the following error message. I read some information which says it is about the 512 bytes limit of qmail about accepting cname lookups but still I don't know what I can do.

    The error message:
    CNAME lookup failed temporarily. (#4.4.3)
    I'm not going to try again; this message has been in the queue too long.
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    /home
    Posts
    80
    Rep Power
    0
    Check if DNS is working on your server. Try ping yahoo.com and see if server is able to resolve domain to IP.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2011
    Posts
    4
    Rep Power
    0

    how to check the dns is working on my server?ping for which server to resolve domain


    Originally Posted by flashwebhost
    Check if DNS is working on your server. Try ping yahoo.com and see if server is able to resolve domain to IP.

    how to check the dns is working on my server?ping for which server to resolve domain
  8. #5
  9. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2006
    Posts
    396
    Rep Power
    11
    Could you check whether your servers /etc/resolv.conf is readable to 'others' ?
    Webhosting.uk.com :: Reseller Hosting | Cloud Server UK | Fully Managed Dedicated Hosting
    Great Opportunity :: Join our Affiliate Program for FREE & earn upto 300! per Sale:clap:

IMN logo majestic logo threadwatch logo seochat tools logo