#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2010
    Posts
    3
    Rep Power
    0

    Can sen but can not receive external mail - qmail


    I got a qmail server at emredoner.net working at CentOs5. I can send mail but can not receive external mail.
    When I send mail from say, deneme(at)emredoner.net to yeni(at)emredoner.net, I receive this mail. But when i send from exxxxxx(at)gmail.com to deneme(at)emredoner.net or yeni(at)emredoner.net I can't receive mail.

    /var/log/maillog is empty

    [root@server log]# telnet localhost 25
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    [root@server log]# telnet localhost 110
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Hello there. <30712.1288769729@localhost.localdomain>
    user deneme(at)emredoner.net
    +OK Password required.
    pass xxxxxxxx
    +OK logged in.
    list
    +OK POP3 clients that break here, they violate STD53.

    [root@server log]# telnet localhost 143
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2004 Double Precision, Inc. See COPYING for distribution information.
    a01 login deneme(at)emredoner.net xxxxxxxx
    a01 OK LOGIN Ok.
    I need serious help im stuck here
  2. #2
  3. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    root@server log]# telnet localhost 25
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    You have to fix this. You have no SMTP server running. Your mailserver can't receive mail without SMTP, that's how other mailservers talk to your server.
    ======
    Doug G
    ======
    It is a truism of American politics that no man who can win an election deserves to. --Trevanian, from the novel Shibumi
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2010
    Posts
    3
    Rep Power
    0
    no as u can see i have SMTP server up and running on port 587, the problem was the xinetd service name smtp 25 was not present. Solved

    Comments on this post

    • crustymonkey disagrees : Listen to Doug. port 587 is for smtp auth. All other servers need to talk to your server on 25...
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2010
    Posts
    2
    Rep Power
    0
    How exactly did you solve this? I am experiencing the same problems.

    Thanks!
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2010
    Posts
    3
    Rep Power
    0
    i checked the /etc/xinitd.d/smtp first line reads "smtp_psa"
    and changed the /etc/xinitd.d/service line;
    "smtp 25" into "smtp_psa 25".
    do you have a smtp server present?
    try
    #telnet localhost 587

    and paste the output.

IMN logo majestic logo threadwatch logo seochat tools logo