1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2009
    Rep Power

    Sendmail 553 when trying to send mail internally


    I've been working on this issue for days without success. I have a server set up in a DMZ. Its hostname is webby.example.com. Mail to example.com is handled by a Microsoft Exchange server on the same network, outside the DMZ. webby.example.com is set up with the following environment.

    Fedora Core 13
    PHP 5.3.2
    Sendmail 8.14.4

    When trying to send mail via sendmail (using php's mail() function) to anything at example.com the sending fails with the following error;

    The original message was received at Tue, 27 Jul 2010 10:13:37 +0100
    from webby2.example.com []
       ----- The following addresses had permanent fatal errors -----
        (reason: 553 5.3.5 system config error)
       ----- Transcript of session follows -----
    553 5.3.5 example.com. config error: mail loops back to me (MX problem?)
    554 5.3.5 Local configuration error
    Mail to external domains e.g. gmail.com, are delivered succesfully.

    I think it has something to do with DNS but not entirely sure and not sure where to go from here.

    Any suggestions?
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Rep Power
    Did you verify the mx record is correct?
    Doug G
    I've never been able to appreciate the sublime arrogance of folks who feel they were put on earth just to save other folks from themselves .." - Donald Hamilton

IMN logo majestic logo threadwatch logo seochat tools logo