#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2012
    Posts
    1
    Rep Power
    0

    Sendmail - not sending mail


    Hi, i need help with this matter since i'm not use with sendmail configuration.

    I have application place in linux server, the OS is redhat and sending email using sendmail 8.13.
    unfortunately the OS was corrupted and was repaired. But after the repair, my application can't send an email any more. I checked the sendmail and it's OK but in maillog, all the email send after the OS incident was queued and not send.

    I try telnet 127.0.0.1 25, it's OK but the email still stuck at queue.
    I try to flush the queue but got error Name server timeout
    Transient parse error -- message queued for future delivery
    and it's seem like the sendmail was configure to use SMARTHOST.
    It look like the sendmail was ok,but something has blocked my email from being sent out.


    Hope someone can guide me how to troubleshoot this matter, I'm just beginner in linux server.

    Sorry for grammatical error, English not my first language
    Thanks for anybody's time
  2. #2
  3. They're coming to take me away

    Join Date
    Jan 2005
    Location
    Florida
    Posts
    5,103
    Rep Power
    5049
    Check your mail logs to see if it gives any useful information.

    In your sendmail config file, you mentioned it using Smarthost. Do you have Smarthost configured to use the correct outgoing server? Some may require that you use the ISP's outgoing server to send mail.

    Have you verified the domain(s) that you need to send with are listed in your outgoing domains?
    "I don't need to get a life. I'm a gamer. I have lots of lives!"

IMN logo majestic logo threadwatch logo seochat tools logo