1. Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Jul 2001
    Rep Power

    form results not displaying / recognising underscore (Nokia 6210)


    I'm using php and wml to take the contents of user input (username and password) and check them against entries in a mysql database. No problem here, unless the user has an underscore in their username...

    I've tried echoing the contents of user input from the form when there's just an underscore in the input, and the result is a blank string. The most frustrating thing about this is that I don't have a wap phone of my own and so have to rely on what the users of the site I'm working on are telling me (an underscore comes out just fine in the online emulators I've tried).

    Any ideas anyone? I've had a search through yahoo and google, but the results I got were to do with variable names rather than inputted text.

    I'd also be interested as to whether or not there are any other symbols that the phones cause problems with (though this won't affect this particular problem, as the usernames in the db are all made up of alphanumerics (and underscores), as are the passwords).

    Thanks guys.
    Last edited by liljim; January 10th, 2002 at 05:34 PM.

IMN logo majestic logo threadwatch logo seochat tools logo