#1
  1. No Profile Picture
    Contributing User
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Dec 2004
    Posts
    3,082
    Rep Power
    379

    links with parameters not working on mobiles/ipads?


    Hi

    i am creating a website which is responsive but on mobile the links do not work?

    the links are of this nature:

    site.com/?p=blog...

    when i press on them nothing happens.. but if i hold press, a menu pop ups saying do you want to open them in new window and if i say yes it all works!

    so Question is how do i make these work on mobile?
  2. #2
  3. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2009
    Location
    Jakarta, Indonesia.
    Posts
    279
    Rep Power
    37
    Hi.
    Perhaps this could help:
    https://developer.apple.com/library/...ingEvents.html

    And, have a link to that page?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Loyal (3000 - 3499 posts)

    Join Date
    Dec 2004
    Posts
    3,082
    Rep Power
    379
    sorry for late reply.. I was using a new library which by defaults if you add events on the link, stop the "Default behaviour".
  6. #4
  7. Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2009
    Location
    Jakarta, Indonesia.
    Posts
    279
    Rep Power
    37
    Err,
    why would it prevent natural behaviour of a link a.k.a. an anchor tag. That's not good, right?
    Or perhaps you intend that link to do something before jumping to other page?

IMN logo majestic logo threadwatch logo seochat tools logo