Hello, i am from spain and my english is horrible, excusme :S

I have a wml page with php code, but this doesn´t work correctly.
I have this:

<?php
// send wml headers
header("Content-type: text/vnd.wap.wml");
echo "<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN""
. " "http://www.wapforum.org/DTD/wml_1.1.xml">";
?>

<wml>
<card id="card1" title="Hello World!">
<p>
<?php


//Conexion con la base de datos
$idDB = @mysql_connect('localhost','','')
or die("No puedo conectar con el gestor");

// Seleccionamos la base de datos
mysql_select_db('Juego',$idDB);


$Persona = $HTTP_GET_VARS['user'];
$Contraseña= $HTTP_GET_VARS['pass'];


//Sentencia SQL para buscar un usuario con esos datos
$ssql = "SELECT * FROM usuarios WHERE User='$Persona' and Password='$Contraseña'";



//Ejecuto la sentencia
$rs = mysql_query($ssql,$idDB);

//vemos si el usuario y contraseña es váildo
//si la ejecución de la sentencia SQL nos da algún resultado
//es que si que existe esa combinación usuario/contraseña

if (mysql_num_rows($rs)!=0)
{ // Todo correcto, mostramos pantalla de bienvenida

print "<br/>Welcome to a PHP-enabled site!";
}
else
{
//si no existe le mando otra vez a la portada

print "<br/>MAL";
}

mysql_free_result($rs);
mysql_close($idDB);

?>

</p>
</card>
</wml>

And WinWap shows this:

Welcome to a PHP-enabled site!"; } else { //si no existe le mando otra vez a la portada print "
MAL"; } mysql_free_result(); mysql_close(); ?>

I have add types for http.conf to Apache and php runs in my local server.

Someone help me?? Please

THANKS.