#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Location
    Central New Jersey
    Posts
    207
    Rep Power
    21

    SSMS is not defaulting to my default database


    Sql Server Management Studio is not changing to my default database when I open a New Query window. I've used the sp_defaultdb and setting via Security > Logins > [login name] > Properties, but neither are working, at least on some servers. On other servers I am still defaulting correctly.

    Is there another way I could try setting this value? Could something on the server prevent it from using the user's default db? (I can get to the database, it just isnt defaulting.)
    Last edited by astroboy71; August 24th, 2012 at 02:52 PM.
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Location
    Central New Jersey
    Posts
    207
    Rep Power
    21
    No one's had this issue before?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Location
    Central New Jersey
    Posts
    207
    Rep Power
    21
    Rookie mistake: A few weeks ago I had set the 'Connect to database:' to the master db on the Login dialog (Connection Properties tab).

IMN logo majestic logo threadwatch logo seochat tools logo