#1
  1. Career Newbie
    Devshed Novice (500 - 999 posts)

    Join Date
    Dec 2005
    Location
    Klamath Falls, Oregon
    Posts
    643
    Rep Power
    11

    7600 GT Evga Won't Install Drivers -- Is it a PSU or Video Card issue?


    Here's my rig.
    http://www.newegg.com/product/product.asp?item=N82E16813121046 (mobo)
    http://www.newegg.com/product/product.asp?item=N82E16814130062 (video card)
    http://www.newegg.com/product/product.asp?item=N82E16822144416 (HD)

    The rest obviously is RAM that I bought from a friend (works awesome, had it tested already 2 gigs of ddr2 667) and a power supply which I need a new one of.

    I had this: http://www.newegg.com/product/product.asp?item=N82E16817171007
    and it blows hard.

    It won't power my video card completely. My rig reboots whenver I try to stress the card (so far that's just installing the drivers). I need more power. My current PSU is 19a and my video recommends 18a. So that's just barely! enough. And this is allegedly a crappy brand (Cooler Master). So now I am the market for a good one.

    What brand do you recommend? I would like to get a 450-500 W one for about 50 dollars before or after shipping.
    I have been using: http://www.eggxpert.com/forums/thread/62618.aspx
    as a way to judge brands.

    Thanks for your opinion and advice!
  2. #2
  3. Career Newbie
    Devshed Novice (500 - 999 posts)

    Join Date
    Dec 2005
    Location
    Klamath Falls, Oregon
    Posts
    643
    Rep Power
    11
    Here are some pics!

    BIOS screen




    This comes up between the BIOS and XP screen. This worries me the most of all.




    My desktop: May not be clear enough.



    Does that look like a messed up vid card to you?

IMN logo majestic logo threadwatch logo seochat tools logo