Page 1 of 2 12 Last
  • Jump to page:
    #1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2001
    Location
    Lisbon
    Posts
    45
    Rep Power
    13

    Exclamation ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)


    I've just installed mysql and while trying to launch Mysql the following error occurs:

    C:\mysql\bin>mysql
    ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)

    Do i need to configure anything anywhere?

    Thanks

    Irina/Lisbon/Portugal
  2. #2
  3. Big Endian
    Devshed Beginner (1000 - 1499 posts)

    Join Date
    May 2001
    Location
    Fly-over country
    Posts
    1,172
    Rep Power
    30
    If MySQL is running you usually get an error about the connection being refused if you have a security problem. Since your error said "Can't connect", I believe this is usually caused when MySQL is not running or you try to connect to the wrong port.

    The search engine on this site will help you find a lot of answers. Go to Search, type in 2203 and you'll get about 20 hits. Take a look through those responses and see if you can find the solution. If you can't, post again with what you tried to do and we'll see if we can solve your problem.
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2003
    Posts
    1
    Rep Power
    0

    Thumbs up


    I am running mysql on windows XP and fixed this error by going into
    c:\mysql\bin and right clicking the "mysqld" file and choosing run as.
    Choose the first option (current user etc..) and hit ok.
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    1
    Rep Power
    0
    Originally posted by chrissanz
    I am running mysql on windows XP and fixed this error by going into
    c:\mysql\bin and right clicking the "mysqld" file and choosing run as.
    Choose the first option (current user etc..) and hit ok.
    It worked for me too. But why?
  8. #5
  9. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    2
    Rep Power
    0
    I am having the same problem but your solution doesn't work for me.
    It works fine on my old PC (win98), I copied the entire dir structure from c:\ to c:\ onto my new winXP machine.
    When I run mysqld-opt.exe it does nothing. There is no mention of it in the task manager and I get the (10061) error message when trying to access it.
    Tried mysqlgui.exe but same result.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    2
    Rep Power
    0
    ...I have now installed mysql 4.0.17 and it's now working fine (phew!)
  12. #7
  13. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    13
    Rep Power
    0
    i'm having the same error but in a diffrent method.

    My Set-up

    Server -
    Linux Debian (Woody)
    Apache
    Mysql
    PHP4

    all latest versions.

    It's all running and working as i can get data via php pages.

    Problem is i need to remote admin the server from a WinXP machine so i've downloaded the mysqlCC file and i get this error code 2003. That do i need to configure on the WinXP machine and/or Linux machine?
  14. #8
  15. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    1
    Rep Power
    0
    Networking for mySQL is turned off by default in Debian. In your /etc/mysql/my.cnf file, just comment out the skip networking line and you should be able to connect from another box using mysqlcc.
  16. #9
  17. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2003
    Posts
    4
    Rep Power
    0

    Smile


    =====================================================================
    Solution for WINXP !!!

    The files are in the wrong place, at least with my example.
    Had an old version of MYSQL.

    Instruction below.(NZ)
    =======================================================================

    I had this problem, and this what helped me.....

    I have Winxp.....

    I removed the previous service, because I had an earlier version....

    /bin/mysqld-nt /remove

    Then I installed the service


    /bin/mysqld-nt /install

    Then I edited the my.ini file, by opening winMysqladmin

    /bin/winmysqladmin
    That command having opened the program...then you should

    then select 4th tab, which is the my.ini file

    You then edit the file to reflect where you had the files of MYSQL...

    as the MY.ini said I had it under c:\mysql ....and I had it under
    another folder altogeather....

    For simplicity sake, I just copied the files from my current folder to
    the specified by my.ini

    This got me the access I wanted....

    Very happy...

    Hope this helps....

    Regards Justin(James)HORT
    From New Zealand, Palmy
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    61
    Rep Power
    11

    Cool WOOHOOOO it works


    thanx for that justy.... works fine now thanx to you......
  20. #11
  21. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Mar 2004
    Posts
    1
    Rep Power
    0

    ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)


    I had the same problem on XP pro and found I had a my.cnf file from a previous install on my c:. I deleted the fiel and everything is working fine now.
    .....for now, anyway
    JokerBoy
  22. #12
  23. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Feb 2004
    Posts
    25
    Rep Power
    0
    Yea I had the same service problem, but ended up reformatting and THEN figuring out what was going wrong Sucked...
  24. #13
  25. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    21
    Rep Power
    0

    Exclamation


    hi
    am doing project using mysql as backend .i do have the same problem.am using win2000.how can i fix this problem.please help me in this regard. i hav followed the steps told in this thread but it coudn't fix my probloem..
    thanks
    simres
  26. #14
  27. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2005
    Posts
    1
    Rep Power
    0

    Lightbulb


    tried several things. finally deleted my.ini file and started over by extracting mysql to my basedir and i just ran mysqladmin which forced me through the process of creating the correct my.ini file that works on xp. it also installed the service.
  28. #15
  29. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2006
    Posts
    2
    Rep Power
    0

    Error can't connect to mysql...


    Originally Posted by IrinaIonela
    I've just installed mysql and while trying to launch Mysql the following error occurs:

    C:\mysql\bin>mysql
    ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)

    Do i need to configure anything anywhere?

    Thanks

    Irina/Lisbon/Portugal
    I faced similar problem.And what I did to solve this problem is:I deleted the my.ini file.To get the location of my.ini file go to command prompt and type C:\>echo %windir%.
Page 1 of 2 12 Last
  • Jump to page:

IMN logo majestic logo threadwatch logo seochat tools logo