#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    2
    Rep Power
    0

    Huge Problem- MySql won't start :(


    Ok, so we have a database with our CDR records in it, and the server went down, and this is the most recent backup. Apparently the guy who did it copied everything live and so corruption is the possible culprit.

    I've already ran myisamchk on the files, and it seemed to do it's thing, but it won't start, here is mysqld.log

    130417 16:38:50 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    130417 16:38:51 InnoDB: Initializing buffer pool, size = 8.0M
    130417 16:38:51 InnoDB: Completed initialization of buffer pool
    InnoDB: Log scan progressed past the checkpoint lsn 1 405160804
    130417 16:38:51 InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    InnoDB: Doing recovery: scanned up to log sequence number 1 405164655
    130417 16:38:51 InnoDB: Starting an apply batch of log records to the database...
    InnoDB: Progress in percents: 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 23:38:51 UTC - mysqld got signal 11 ;
    This could be because you hit a bug. It is also possible that this binary
    or one of the libraries it was linked against is corrupt, improperly built,
    or misconfigured. This error can also be caused by malfunctioning hardware.
    We will try our best to scrape up some info that will hopefully help
    diagnose the problem, but since we have already crashed,
    something is definitely wrong and this may fail.

    key_buffer_size=8384512
    read_buffer_size=131072
    max_used_connections=0
    max_threads=151
    thread_count=0
    connection_count=0
    It is possible that mysqld could use up to
    key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 338332 K bytes of memory
    Hope that's ok; if not, decrease some variables in the equation.

    Thread pointer: 0x0
    Attempting backtrace. You can use the following information to find out
    where mysqld died. If you see no messages after this, something went
    terribly wrong...
    stack_bottom = 0 thread_stack 0x40000
    /usr/libexec/mysqld(my_print_stacktrace+0x29) [0x84e0a9]
    /usr/libexec/mysqld(handle_fatal_signal+0x483) [0x6a2743]
    /lib64/libpthread.so.0(+0xf500) [0x7f555d4b7500]
    /usr/libexec/mysqld(page_cur_insert_rec_low+0x288) [0x797178]
    /usr/libexec/mysqld(page_cur_parse_insert_rec+0x4eb) [0x797d1b]
    /usr/libexec/mysqld() [0x78517d]
    /usr/libexec/mysqld(recv_recover_page+0x34f) [0x786c3f]
    /usr/libexec/mysqld(buf_page_io_complete+0x548) [0x7485d8]
    /usr/libexec/mysqld(fil_aio_wait+0xfa) [0x7604ca]
    /usr/libexec/mysqld() [0x7c6380]
    /lib64/libpthread.so.0(+0x7851) [0x7f555d4af851]
    /lib64/libc.so.6(clone+0x6d) [0x7f555bbfe11d]
    The manual page at xxxxxxxxxxxxxxx contains
    information that should help you find out what is causing the crash.
    130417 16:38:51 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended


    I really need to get this database back up, or at the very least extract the information from it.

    Please let me know what else i can do.
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2013
    Posts
    2
    Rep Power
    0

    Cool Solved


    Solved with this thread


    in my.cnf (or mysql option file):
    add to [mysqld] section
    innodb_force_recovery = x

    then start mysqld, start with x = 1 then work up to 6, once mysql starts, then run mysqldump to dump data to file.

    Then total clean out mysql and re-import clean.
    Also, a personal note:

    be sure that mysql is the user and group of all directories and files from /var/lib/mysql - or whatever user mysql runs as.
    Last edited by themrrobert; April 18th, 2013 at 04:24 PM. Reason: added notes

IMN logo majestic logo threadwatch logo seochat tools logo