1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Rep Power
    I have tried everything but keep having problems with the mysql.sock unix socket file. First I installed the normal way (source compile) and kept having problems with the socket. I tried to change the path from the default (/tmp/mysql.sock) to a new path (/usr/local/mysql/socket/mysql.sock). It still didn't work and the documentation says to try a binary install. I did this and it works fine now except for one thing.

    When I run "mysqladmin variables" it correctly identifies the socket path (/tmp) but when I try to connect from a browser via PHP, it says that it is unable to connect to msyql via socket /usr/local/mysql/socket/mysql.sock. I have tried to set the socket path both in the invocation of safe_mysqld in the mysql.server script and using a /tmp/my.cnf file but to no avail. Any ideas?

    Last edited by talambert; September 24th, 2003 at 11:52 AM.

Similar Threads

  1. problem with relative paths
    By Wizard2003 in forum XML Programming
    Replies: 4
    Last Post: August 26th, 2003, 12:43 AM
  2. absolute path include problem
    By kubicon in forum PHP Development
    Replies: 2
    Last Post: July 31st, 2003, 12:29 PM
  3. path problem in c++ under linux
    By hbogdan in forum C Programming
    Replies: 1
    Last Post: July 21st, 2003, 12:42 PM
  4. Slash problem in path...
    By BladeTMC2 in forum PHP Development
    Replies: 0
    Last Post: June 17th, 2002, 06:29 AM
  5. Wierd Mail problem.. Urgent help required...
    By Jollyguy in forum PHP Development
    Replies: 2
    Last Post: May 2nd, 2002, 12:37 PM

IMN logo majestic logo threadwatch logo seochat tools logo