Actually i meet two question when i installed the MySQL on SGI IRIX6.4 and FreeBSD3.2.
The following is these:
1.On SGI O200 IRIX6.4
After installed,skip some warning,i run /bin/mysql_install_db,the system display:
# ./mysql_install_db
Creating db table
Creating host table
Creating user table
Creating func table
Creating tables_priv table
Creating columns_priv table
./mysql_install_db[238]: 23314 Memory fault(coredump)
Installation of grant tables failed!

Release: mysql-3.22.32 (Source distribution)
<machine, os, target, libraries (multiple lines)>
System: IRIX64 server-5 6.4 02121744 IP27

Some paths: /usr/sbin/perl /sbin/make /usr/bin/gcc /usr/bin/cc
GCC: Reading specs from /usr/local/lib/gcc-lib/mips-sgi-irix6.4/2.8.1/specs
gcc version 2.8.1
Compilation info: CC='gcc' CFLAGS='' CXX='gcc' CXXFLAGS='' LDFLAGS=''
Configure command: ./configure --with-unix-socket-path=/var/tmp/mysql.sock --with-low-memory --with-mit-threads=yes
Perl: This is perl, version 5.003 with EMBED

Whether i run ./configure --option(difference some arguments) every time,
the system's message is the same.I don't know why and i use gcc2.95.2.
These are not some host,user,func etc. tables in DB mysql.

2.On PC FreeBSD 3.2
I installed MySQL every time,run ./mysql_install_db ,the system is correct,but
run ./safe_mysqld or some to starup server,the system display don't find the mysql.sock file in set path directory.
The system display:


>Release: mysql-3.23.21-beta (Source distribution)

<machine, os, target, libraries (multiple lines)>
System: FreeBSD 3.2-RELEASE FreeBSD 3.2-RELEASE #0: Tue May 1
8 04:05:08 GMT 1999 jkh@cathair:/usr/src/sys/compile/GENERIC i386

Some paths: /usr/bin/perl /usr/bin/make /usr/bin/gcc /usr/bin/cc
GCC: gcc version
Compilation info: CC='gcc' CFLAGS='' CXX='c++' CXXFLAGS='' LDFLAGS=''
-r--r--r-- 1 root wheel 1043748 May 18 1999 /usr/lib/libc.a
lrwxrwxrwx 1 root wheel 9 Mar 4 15:44 /usr/lib/ ->
-r--r--r-- 1 root wheel 514015 May 18 1999 /usr/lib/
Configure command: ./configure --prefix=/usr/local/mysql --with-unix-socket-pat
Perl: This is perl, version 5.005_03 built for i386-freebsd

sbw# ./mysqladmin version
./mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/usr/local/mysql/tmp/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/usr/local/mysql/tmp/mysql.sock' exists!

I saw the manaul about security according the system prompt ,but i have no way to try it the cause.
The mysqld.sock is not there.After i installed it evrey time,i didn't see it.
You think the mysql.sock is danymic created,Why is not?
I don't know where it go.

My two servers are not successful,i am URGENT.

I hope someone gives me some advice.

Best regards,

shan baowei