#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Posts
    12
    Rep Power
    0
    sbw#./mysqlbug

    >Release: mysql-3.23.21-beta (Source distribution)

    >Environment:
    <machine, os, target, libraries (multiple lines)>
    System: FreeBSD sbw.freebsd.com.cn 3.2-RELEASE FreeBSD 3.2-RELEASE #0: Tue May 1
    8 04:05:08 GMT 1999 jkh@cathair:/usr/src/sys/compile/GENERIC i386


    Some paths: /usr/bin/perl /usr/bin/make /usr/bin/gcc /usr/bin/cc
    GCC: gcc version 2.7.2.1
    Compilation info: CC='gcc' CFLAGS='' CXX='c++' CXXFLAGS='' LDFLAGS=''
    LIBC:
    -r--r--r-- 1 root wheel 1043748 May 18 1999 /usr/lib/libc.a
    lrwxrwxrwx 1 root wheel 9 Mar 4 15:44 /usr/lib/libc.so -> libc.so.3
    -r--r--r-- 1 root wheel 514015 May 18 1999 /usr/lib/libc.so.3
    Configure command: ./configure --prefix=/usr/local/mysql --with-unix-socket-pat
    h=/usr/local/mysql/tmp/mysql.sock
    Perl: This is perl, version 5.005_03 built for i386-freebsd
    ~

    ***************************************************************
    sbw# ./mysqladmin version
    ./mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/usr/local/mysql/tmp
    /mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/usr/local/mysql/tmp/mysql.so
    ck' exists!
    ****************************************************************

    I saw the manaul,but i have no way to try it.
    The mysqld.sock is not there.After i installed it,i didn't see it.
    I don't know where it goes.


    cheers,
    shan baowei
    sbwtxj@263.net
    sbwtxj@sina.com

    ------------------
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jun 2000
    Posts
    36
    Rep Power
    15
    The default is for it to be created in /tmp/mysql.sock. It is created by the daemon when you launch, NOT at install. It is destroyed when you shutdown
    (using mysqladmin shutdown).

    I had a lot of problems with this at first. The official solution is to simply use a binary distribution, which apparently doesn't have the problem of the missing socket.

    I tried that, but wanted the flexibility of my own compile. My solution was to totally remove both the mysql program and the source files (though you might achieve the same by deleting config.cache and your make file, I wanted to be absolutely sure). Then I recompiled, explicity specifying the socket location as a config parameter. It's worked flawlessly since.

    Cheers
    Tom
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    May 2000
    Posts
    73
    Rep Power
    15
    try this it may work

    /etc/inet.d/mysql start

    or else

    the path to mysqld/mysqld &

    eg.
    /usr/local/bin/mysqld &
  6. #4
  7. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2000
    Posts
    16
    Rep Power
    0
    Just a few things:

    In the mysql-3.2x/scripts directory:

    1. Make sure you run the mysql_install_db script from the distribution.

    2. run safe_mysqld

    Hope this helps.

Similar Threads

  1. Fixing a partial install on FreeBSD
    By samuelelliot in forum BSD Help
    Replies: 2
    Last Post: January 31st, 2004, 10:11 PM
  2. redhat 9 laptop install issues
    By don_sparko in forum Linux Help
    Replies: 2
    Last Post: September 25th, 2003, 11:55 PM
  3. could not install BerkeleyDB
    By bln in forum Perl Programming
    Replies: 2
    Last Post: February 21st, 2003, 12:39 AM
  4. "Properties" inaccessable after bad W2K SP3 install
    By Azraelle in forum Windows Help
    Replies: 0
    Last Post: November 16th, 2002, 07:45 PM
  5. 4.2.2 + gd: install problems on linux
    By merkinmuffley in forum PHP Development
    Replies: 0
    Last Post: July 24th, 2002, 06:18 PM

IMN logo majestic logo threadwatch logo seochat tools logo