1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2000
    Rep Power
    In Redhat Linux 6.2 I tried to complie MySQL C API client program but

    The gcc command I used was :

    gcc -I/path_to_mysql/include/mysql -L/path_to_mysql/lib/mysql myprogram.c -lmysqlclient

    Though the compiling was successful,but it showed a error message when I ran the *.out file:

    error in loading shared libraries: libmysqlclient.so.6: cannot open shared object file: No such file or directory

    but why?I didn't have any idea at all......
  2. #2
  3. No Profile Picture
    Devshed Newbie (0 - 499 posts)
    I have been seeing similar message like yours almost once a day here.

    I still don't know why nobody takes advantage of the "search" link found on this page at all.

    Anyway, start here -> http://www.devshed.com/Talk/Forums/F...ML/002149.html

Similar Threads

  1. Missing icons, taskbar, start menu
    By Richard747 in forum Windows Help
    Replies: 31
    Last Post: July 21st, 2005, 07:40 AM
  2. Win 98 - Blue Screens, Freezing, and constantly Rebooting.
    By RosaAeterna in forum Windows Help
    Replies: 15
    Last Post: February 20th, 2004, 11:50 AM
  3. Replies: 1
    Last Post: January 27th, 2004, 02:02 PM
  4. Replies: 1
    Last Post: January 27th, 2004, 01:13 PM
  5. Problems running external program through Perl
    By Duncs in forum Perl Programming
    Replies: 1
    Last Post: January 5th, 2004, 01:45 PM

IMN logo majestic logo threadwatch logo seochat tools logo