#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Posts
    30
    Rep Power
    11

    IIS configuration problem for asp.net


    Hi
    i was trying to develop a webform for the visualbasic.net program i created ..i saved the file ..and when i triend to view this webpage i am getting the following error..is there any thing to be changed in the iis configuration
    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.
    Here is the error i got
    Source Error:


    Line 23: "Forms", "Passport" and "None"
    Line 24: -->
    Line 25: <authentication mode="Windows" />
    Line 26:
    Line 27:


    Source File: c:\inetpub\wwwroot\WebLoanCalculator\web.config Line: 25


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1




    thanks
    ganesh
  2. #2
  3. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    2
    Rep Power
    0
    Hi,

    I think your problem is becoz ur machineconfiguration and your webConfiguration files have different settings.

    Try to change the authentication session either in the Machine.config file or in th wed.config in ur present working application.

    Thanks,
    Manu007
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2003
    Posts
    8
    Rep Power
    0
    Id also suggesting setting the authentication mode to ="None" if you're nt using the windows one for anything (by memory that is just the Vis studio default) <--shameless self promotion by our friend bill
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Apr 2000
    Location
    Redmond, WA
    Posts
    218
    Rep Power
    14
    is the directory where the application lives configured as an application directory in IIS?

    hit windows-r, type iismgr, right click on default web site, go to properties, click on the home directory tab and look at application settings. click on the 'create' button and you should be all set.

IMN logo majestic logo threadwatch logo seochat tools logo