I had a problem with my Frontpage extensions. I wanted to run FrontPage 2002 and only had FrontPage Extensions 2000. I upgraded to extensions 2002 and my .Net stopped working.

Prior to all of this happening I upgraded to IIS 1.1.

I am using Windows XP Pro.

I tried to fix the problem as described below.

1] uninstal IIS 1.1
2] uninstall FrontPage Extensions 2002
3] Uninstall Framework 1.1
4] uninstall Framework 1.0

1] installed IIS
2] Installed FrontPage Server Extensions 2002
3] Tried to install Framework 1.0 and received the following message:

Error - 1935 {B628937F-4466-6820385A5C0A}
HResult = -2147319761

I also uninstalled and reinstalled iis and tried to just install framework 1.0 without the FrontPage extensions and got the same results.

I tried to do this from my cd as well as the Microsoft web site.

When this didn't work, I tried to just install IIS 1.1 without first installing IIS 1.0.

I then installed FrontPage extensions 2002.
This was succesful.

I then installed Frameworks 1.1 succesfully.

However, when I tried to open a solution in Visual Studio,Net I received the error message below:

Project 'using windows' could not be opened because the Microsoft Visual Basic .Net compiler could not be created.

Cannot find the .Net Framework directory.

System error &H80131700&

Any suggestions?