#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    3
    Rep Power
    0

    I need help setting up FTP access for 3 WD MY BOOK LIVE DUO Drives


    Hello,

    So I have a home network, and I have connected 3 WD MY BOOK LIVE DUO's NAS drives.

    They each have a unique and static IP address.
    Under the network settings I have enabled FTP access, but configuration screen does not allow you to change the FTP port.

    Within my router, I have enabled port forwarding for all 3 drives, entering each of the IP addresses, the from port (21) and the to port (21).

    When I go to a browser, I type my wan IP address followed by port 21 and it asks for user name and password, but this accesses my first drive.

    How can I access my other 2 drives via FTP?
    Thanks
  2. #2
  3. Lord of the Dance
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Oct 2003
    Posts
    3,535
    Rep Power
    1906
    Standard, you can only map one port to one IP. (sometimes it can possible in case of load balancing)

    What happens if you try to map incoming at WAN port 22 to LAN port 21 for the second device/IP?
    If this doesn't work, I think the only possibility is to get another NAS that support your needs.

    You didn't thought about FTP when you got those NAS? (hindsight is a good but annoying way to learn )
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    3
    Rep Power
    0

    Response


    Additionally,

    I have enabled ssh on the drives and can login using putty, within the vsftpd.conf file, all 3 drives have a port setting of 21.

    Could I changes these?
    If I did change these to something else, what would you recommend? And how would I set up port forwarding... the incoming and the outgoing ports?

    Thanks
  6. #4
  7. Lord of the Dance
    Devshed Expert (3500 - 3999 posts)

    Join Date
    Oct 2003
    Posts
    3,535
    Rep Power
    1906
    Before you start changing something, BACKUP the files first.
    Can't guarantee anything of what might be possible or work.

    What port number to use is up to you, something higher than 1024 (lower port numbers are reserved)

    For incoming, you said you already have the IP in the router configured with port 21, so you will have to change port numbers to what you have on the NAS.

    I suggest you take look at this page:
    http://serverfault.com/questions/421161/how-to-configure-vsftpd-to-work-with-passive-mode
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Sep 2013
    Posts
    3
    Rep Power
    0

    Response


    Hey,

    So I was able to resolve the issue by changing the incoming ports to different ports, thank you!

IMN logo majestic logo threadwatch logo seochat tools logo