Recently my office switched to a new ISP and phone service (comcast). We have (or should have) a static IP.
Mixed wired and wireless access. The internet works but I can't access my server anymore.
Just 5 PCs, I think on a workgroup (not a domain), and 1 server.

Comcast guy is gone. I'm not qualified to fix this but might be able to with your help.

I think my main issue is a lack of understanding about the difference between the IP settings in the modem, vs. the router.
If I am connected wirelessly, and I go to the browser and put in 10.1.10.1, I get the WRT54G router settings page.
If I am connected with wires, and I put in 10.1.10.1, I get the comcast modem settings page.

The comcast guy wrote down the static IP info, DNS, etc... which of the two settings pages mention above gets this info?

Right now, the network goes like this:
Internet --> Comcast modem --> big switch in server closet --> server + various PCs + WRT54G wireless router.

Should it be set up differently, maybe Internet --> Modem --> Wireless Router --> Switch?

What would I plug into the server's TCP/IP properties box? It has just one adapter. I've tried various settings in this box but nobody sees the server. However the server gets online fine. I didn't touch any other server settings.

----------------------------------------------------------------------------------------------------------------

My IPconfig (wireless... I don't have wired available from this PC):

Wireless LAN adapter Wireless Network Connection 5:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Linksys AE1000
Physical Address. . . . . . . . . : 68-7F-74-72-27-AA
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::19f2:34ee:24c1:27ea%19(Preferred)
IPv4 Address. . . . . . . . . . . : 10.1.10.102(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, November 21, 2012 3:11:31 PM
Lease Expires . . . . . . . . . . : Thursday, November 22, 2012 3:43:46 PM
Default Gateway . . . . . . . . . : 10.1.10.1
DHCP Server . . . . . . . . . . . : 10.1.10.1
DHCPv6 IAID . . . . . . . . . . . : 426278772
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-F7-14-6F-90-FB-A6-89-E5-38

DNS Servers . . . . . . . . . . . : 75.75.75.75
75.75.76.76
NetBIOS over Tcpip. . . . . . . . : Enabled

===========================================
===========================================

Is there any other info I can post that might help make sense of all this?