Big problems with my network! Where would you guys check?

Ok, had big problems with my network last night.

My setup:

Garage converted to office, with 3 double network sockets installed in walls.
Cabling has been dug underground in waterproof pipe to take it to house (source of internet connection)
Internet is coming via a wireless box mounted on the side of the house which connects wirelessly to a fibre line 6 miles away (this works fine, supplied by Netserve, company Rhod works for)
3 pcs in office 2 running Linux (1 Ubuntu, 1 Mint) and 1 running Windows 7 (built today)
All connected to a WRT54G router with DDWRT installed.

(Several wireless devices are running on the network too, but these are all fine)


Before today, we had the two Linux machines running perfectly. However I had noticed if we tried to change the network socket they were plugged into, they wouldn't reconnect, so this could be pre existing, but it never bothered me.

Yesterday I setup a new pc running windohs (for a new guy starting today). We had to move the furniture around in order to fit him in, so one of the existing Linux (Ubuntu) machines moved next to another network point.

Plugged everything in and had problems straight away.

Linux (Mint) machines connection dropped, even though it hadn't been touched.

Linux Ubuntu wouldn't connect.

Windohs 7 wouldn't connect.

Checked Windohs 7 network adaptor and it kept jumping between Connected, Connecting, Initializing and Unplugged in quick succession in a never ending loop.

Got Linux Mint to connect on its own, but other 2 are not on the network.

Things I have tried/notes:

At one point I had windohs 7 and Linux mint both connected with static IPs. Went to connect Linux Ubuntu to the mix (via static IP as I assumed this would work like the other two), and the other 2 disconnected by the time I got back to check them.

I have tried connecting with static IPs and dynamically assigned IPs.

I have removed the DDWRT router and used a Netgear WG834N in its place. They all connected to this, but if cannot get the internet running through this. Attempted to hook the DDWRT router to the Netgear as a combo solution, but got lost in the settings. Basically I assigned the Netgear an ip of and turned DHCP off for this router. I set to use a static IP address of (DDWRT) for the internet connection, and left DDWRT to handle DHCP.

A mac laptop wired in via 1 cable directly to the back of the router (not via a socket wired to the router) works fine.

All wireless connections are fine.

I have tried connecting all the network sockets to an 8 port switch and then connecting that to the router, to no effect.

Network cables have been tested.

Sockets have been tested.

Computers seem to work fine independently.

Banging my head against a wall here, what would you guys try next?