#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    4
    Rep Power
    0

    Moving from 3com switch to a Cisco switch


    Hi All,

    I currently have a 3com network switch enviornment.
    As these switches fail I am replacing them with Cisco switches.

    Upto now I have replaced 4 switches without any issues.

    However I have come across one where I am having issues with a couple of devices not working as expected when moved on the Cisco switch.

    A little background info:
    I have VMWare servers on a Dell 2900 chassis and a Dell EqualLogic san.

    one of the servers is configured with two Nics.
    Lets say Nic 1 for the local Lan and nic 2 for an alaram \ monitoring system

    Nic 1 for the local lan is configure with a DG and DNS server (local DC) 10.x

    Nic 2 just has an IP and subnet. 192.x

    attached to the alarm system is a moxa which take serial conenction converts it to IP and squirts it over to the server the on nic 2. currently everything works as it should.

    From my laptop I cannot ping Nic 2 on server (not surprised as it has no DG so doesnt know how to get back to me)

    On the 3com switch that Nic 2 is connected the port is configured as being in vlan 7 but is an untagged member port.

    On the server is a small program that receives packets from the moxa. it counts up 2 points every second (this is how I know its working)

    When I connect this cable to the cisco switch to a port configured as an access port on vlan 7 the config doesnt work.

    There is no special routing going on within the 3com switch network and there are no static routes configured or learned within the Cisco switch.

    I have also tried configuring the port on the Cisco as a trunk but that didnt work either.

    The Moxa has an IP address on the 192.x network and from my laptop I can ping it. There is a 3com backbone switch with vlan 7 configured with a 192.x ip address both these addresses are pingable from the Cisco switch so it knows how to get there...

    Can anyone offer any adivce on how I can get this working?

    Thanks
    Shaun
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,408
    Rep Power
    2004
    Hi Shaun,

    I'm not familiar with the type of Moxa product you are using, but if I understand correctly, it connects to your network via a network port on the switch and monitors data? Does it gather data and then shoot it over to your server via network traffic or another medium?

    Is the switch a Layer 2 or Layer 3 switch (if you don't know just tell us the model number).

    Is it possible there's something in the config file the Moxa uses that needs to be adjusted? Wouldn't hurt to see a print out of the running config file on the Cisco switch either.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    4
    Rep Power
    0
    Hi Seack,

    Thank you for taking the time to reply.

    I dont think the Moxa type is that important. Its connected to an alarm and monitoring system via serial connection and collects data from that. it then converts the data to ip format and squirts it over to the server via the network.

    I believe the Moxa a Siemens OSM TP62
    I did try linking to t but as a noob not allowed


    its a layer 3 Cisco switch (3750x 24-P) model.

    There is no fancy config on the switch.
    a couple of vlans only vlan 1 has an ip 10.x network for lan.

    on the 3com switch that is failing it has an ip address which I thought there maybe some routing to it. I changed the Cisco IP address to that of the 3com and removed the 3com from the network. However this still did not work.

    I can get you a copy of the running config tomorrow from both Cisco and 3com. However off top of my head its conencted as this:
    Cisco gi1/1/1 connected via fibre to 3com Backbone switch 4
    3com switch connected via fibre to 3com Backbone switch 4

    Cisco Config:
    interface GigabitEthernet1/1/1
    description Link To BS4 Unit 2 Port 2
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,5-7
    switchport mode trunk

    interface GigabitEthernet1/0/9
    description Link to server for AMS
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast

    interface Vlan1
    ip address 10.20.103.233 255.255.252.0

    interface vlan 7
    description Alarm system
    no ip address

    I have had a Cisco expert login remotely to try and get this working but was unable to.

    Is it possible to change gi1/0/9 from L3 port to L2 port ?
    Would this even make a difference?
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Oct 2013
    Posts
    4
    Rep Power
    0
    Below is a copy of the running config:


    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname LS34
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5
    !
    !
    !
    no aaa new-model
    clock timezone UTC 1
    clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
    switch 1 provision ws-c3750x-24p
    system mtu routing 1500
    !
    !
    !
    !
    crypto pki trustpoint TP-self-signed-901702912
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-901702912
    revocation-check none
    rsakeypair TP-self-signed-901702912
    !
    !
    crypto pki certificate chain TP-self-signed-901702912
    certificate self-signed 01
    3082023B 308201A4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 39303137 30323931 32301E17 0D393330 33303130 30303132
    355A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
    532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3930 31373032
    39313230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
    CA7BFBF6 A88E3B4B EE656BED 8B250BDD EF2661AA 9E33DC0D 2488F60F 99F77B63
    8789ED41 65764F19 B1F8C039 C3BC4543 BE9A5604 4E9E762F 2B664FD7 C4DF77B3
    A800B701 12939910 614B73F4 555BC851 19132C43 EFACC4E9 49732DE4 13EF8364
    11D75D81 76178DF9 128D67F1 97262555 EAA6950E 20C02C6E EB283DA0 AC8AC5CD
    02030100 01A36530 63300F06 03551D13 0101FF04 05300301 01FF3010 0603551D
    11040930 0782054C 5333342E 301F0603 551D2304 18301680 14675DE2 E4E3034C
    39FD576E F683C966 1699585D C0301D06 03551D0E 04160414 675DE2E4 E3034C39
    FD576EF6 83C96616 99585DC0 300D0609 2A864886 F70D0101 04050003 81810011
    59FBC349 A8B36E2D E227261B 2C3148B0 77AFB81C 7B13A5F2 805381A9 A6927557
    0190AEC2 82011C88 22EFE365 2BFD20D4 E3BF1403 A3C71F17 C01D0680 F4EC8ABA
    23154577 B635D8A6 E5761761 86C6080F 15D6F72A 64B8C830 52FC88AD 3B219146
    188A91EA B73F7C49 19D2CBE7 AD4456E8 80219B3F 68BEA172 90732654 8C49BA
    quit
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet0
    no ip address
    !
    interface GigabitEthernet1/0/1
    description Techman-Server
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/2
    description Media PC
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/3
    description AV Room Phone
    switchport access vlan 5
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/4
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/5
    description VoiceGear
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/6
    description Laundry Phone
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/7
    description Dry Store Phone
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/8
    description Pump Room Phone
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/9
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/10
    description WF33 Outside AV Room
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/11
    description SVP Processor
    switchport access vlan 6
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/12
    description WF45 Pump Room
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/13
    description Mitel PBX
    switchport access vlan 6
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/14
    switchport access vlan 5
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/15
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/16
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/17
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/18
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/19
    switchport access vlan 7
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/20
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/21
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/22
    switchport mode access
    switchport voice vlan 6
    spanning-tree portfast
    !
    interface GigabitEthernet1/0/23
    !
    interface GigabitEthernet1/0/24
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    spanning-tree link-type point-to-point
    !
    interface GigabitEthernet1/1/1
    description Link To BS4 Unit 2 Port 2
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,5-7
    switchport mode trunk
    spanning-tree link-type point-to-point
    !
    interface GigabitEthernet1/1/2
    !
    interface GigabitEthernet1/1/3
    !
    interface GigabitEthernet1/1/4
    !
    interface TenGigabitEthernet1/1/1
    !
    interface TenGigabitEthernet1/1/2
    !
    interface Vlan1
    ip address 10.20.103.233 255.255.252.0
    !
    interface Vlan2
    description Equinox
    no ip address
    !
    interface Vlan5
    description VBH
    no ip address
    ip helper-address 10.20.100.22
    !
    interface Vlan6
    description Voice
    no ip address
    ip helper-address 10.20.160.1
    !
    interface Vlan7
    description AMS
    no ip address
    !
    interface Vlan9
    description VSat
    no ip address
    !
    interface Vlan11
    description Shore ADSL
    no ip address
    !
    interface Vlan50
    description Crew Wifi
    no ip address
    !
    interface Vlan100
    description Internet
    no ip address
    !
    interface Vlan103
    description MTN Network
    no ip address
    !
    interface Vlan105
    description VLAN 105 MGMT
    no ip address
    !
    interface Vlan111
    description Ubiquity Wifi
    no ip address
    !
    ip default-gateway 10.20.103.244
    ip classless
    ip http server
    ip http secure-server
    !
    !
    !
    line con 0
    line vty 0 4
    password
    login
    line vty 5 15
    password
    login
    !
    end


    Thanks
    Shaun
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,408
    Rep Power
    2004
    Hi Shaun,

    Sorry for the delay, I've been out on vacation. Just to confirm, you can ping the Moxa device from the server correct?

    If the Cisco expert could not resolve the issue let's work under the assumption (hopefully correct lol) that it doesn't have to do with the Cisco switch. Is there a possible config file that needs to be adjusted?

    When you say it doesn't work, do you mean your laptop can't read the data, the server isn't obtaining (and storing) the data, or both?

IMN logo majestic logo threadwatch logo seochat tools logo