#1
  1. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24

    Question Networking two Win2K machines


    Hi,

    I've just bought a USB/Ethernet thingy so to network together a laptop and a desktop machine. I have a crossover CAT5 cable to connect them.

    Thing is, I've got both of them set up as Microsoft Client/File and Print Sharing and TCP/IP, they occasionally see each other on the network, but wont actually access each other, I just get \\[computer name] or [workgroup] not accessable.

    This isn't exactly my area of expertise, so I'm throwing it open.

    A detailed guide through what to do would be very helpful.

    Oh, and I want to share an internet connection, but that aint working either.

    Help!
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2001
    Posts
    190
    Rep Power
    13

    Re: Networking two Win2K machines


    Originally posted by binky
    ...they occasionally see each other on the network...
    Do you mean that they don't appear on each other's screens? Does it happen frequently?

    ...but wont actually access each other, I just get \\[computer name] or [workgroup] not accessable.
    Does it want you to log in? What do you log in as? If it is Guest, have you enabled that account?


    Oh, and I want to share an internet connection, but that aint working either.
    I've never got it working either.
  4. #3
  5. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    Make sure both computers have the same IP subnet and have the same workgroup name. You probably want to add the same username/password account to both computers so you can log on either computer the same way.

    Internet Connection Sharing works well if you are on dialup and have a modem in one machine. Set up your dialup network connection then select the "I want to share this connection". Doing this enables a DHCP server on the connecting computer and establishes a local network subnet of 192.168.0.x with the connecting computer having 192.168.0.1 address.
  6. #4
  7. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24
    The subnets are both 255.255.255.0 and the IPs are 192.168.0.2 and 192.168.0.3 respectively. They also are in the same workgroup.

    The connection to the Internet is through ADSL... if that's any problem?

    Surely they should be able to see each other though, even if they can't share a connection yet?

    Right, seen the share connection on the dial up properties. But the LAN isn't connected at the moment, so I will give that a go tomorrow.
  8. #5
  9. No Profile Picture
    Stumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,409
    Rep Power
    4538
    Internet connection sharing and networking between the two computers are pretty independent of each other.

    Can you map a drive between the two? You can use \\<computer>\c$ to try to connect to the "admin" share.
  10. #6
  11. Perl Monkey
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    May 2003
    Location
    the far end of town where the Grickle-grass grows
    Posts
    1,860
    Rep Power
    108
    ping each others' ip and/or name? Failing that, if you ping by name, does it say "can't reach host" or "unknown host" ?

    Also, check the "active connection" lights on the USB cards themselves.

    Since you mentioned ASDL, I assume the desktop has two network cards? One for the modem and one for the LAN?
  12. #7
  13. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24
    When I go to the work group on the desktop, the laptop is there. But then when I click on the laptop it says:

    \\<computer> is not accessible.

    The network path was not found.

    If I ping the laptop it returns the pings. But if I ping from the laptop, it times out.

    Both computers have the same account uname/pw

    Mapping a drive doesn't work either.

    The desktop appears to be sending and recieving loads of data, the laptop has sent very little, if any. The laptop also can't seem to find the workgroup. With a similar message to the one above.
  14. #8
  15. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24
    Okay, figured out ZoneAlarm was stopping the computers talking to each other. They can now access each others hard-drives. But the internet connection isn't being shared.

    ADSL and NIC are two separate entities...
  16. #9
  17. No Profile Picture
    :: cerebralshock ::
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    Everywhere & nowhere.
    Posts
    133
    Rep Power
    12
    Try using two single-direction CAT5 cables (CAT5e will be quicker and more stable as well). The connection will only be stable if the hub/router has correction on it to decipher the crossover in the cable.
  18. #10
  19. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24
    No hub/router, so single direction Cat5 would be a teenswy-weensy bit of a problem.

    It is CAT5e also...
    I've found a site that may provide the key, if it does then I will post a solution to the whole kit-and-kaboodle as if I know what the hell I'm talking about.
  20. #11
  21. No Profile Picture
    :: cerebralshock ::
    Devshed Newbie (0 - 499 posts)

    Join Date
    Aug 2002
    Location
    Everywhere & nowhere.
    Posts
    133
    Rep Power
    12
    Make sure they're running the same Workgroup. Go to System Properties and Network Identification. Make sure the properties are identical (except the computer name). Use the Properties button, not the Network Wizard (it's crap).

    Use testing values 192.168.0.1 and 192.168.0.2 for each, with a subnet of 255.255.255.0

    I assume the PC is using a PCI NIC and the laptop an onboard of PCMCIA card? Laptops to PCs are always slower.

    Also try enabling WINS on each computer, giving the other one's IP address as the Primary WINS server. Enable LMHOSTS Lookup.
  22. #12
  23. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2003
    Location
    Mississippi
    Posts
    475
    Rep Power
    11

    2k nw


    first make sure the network card drivers are installed by going to my computer, control panel, system, hardware, device manager , while your there check the network identification tab , go to properties, make sure both machines have the same workgroup name, if they do they should see each other then, if not use the network id tab on that page, it is like a set up wizard, use auto detect settings, do the same on the other machine. as far as the internet connection, connect to the internet with the machine that goes on the net, then on the client, right click the internet explorer icon, select properties, connections, click the set up tab, put a dot in, i want to set up my connection manually, or i connect through a local area network, the last option on that list, click next, put a dot in i connect through a local area network(lan). click next, make sure there is a check in automatic discovery of proxy server(recommended), click next, up to you if you want to set up outlook express, finnish. surfs up dude
  24. #13
  25. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24
    Added the WINS bit... other bits had already been done. Now, I've taken PGP off, and when I open IE on the laptop the internet connection starts up on the PC, but the laptop IE then says that the page cannot be found. So it is doing something. Though now I have no PGP or Firewall running. Great...

    Any ideas now?
  26. #14
  27. Contributing User
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Oct 2001
    Location
    New Zealand
    Posts
    1,774
    Rep Power
    24

    Smile Yeah baby Yeah!


    Finally got it happening, though the firewall doesn't support networking, to share files, the internet connection is finally up and running.

    The solution is that it required the preferred DNS not to be assigned automatically, but to be set as the DNS of the ISP. Never said anything about that anywhere.

    So there you have it. Cheers for your help. Systems are set up as:

    DESKTOP
    ------------
    DHCP service running,
    DSL connection enabled for internet connection sharing,
    LAN connection, tcp (192.168.0.1) subnet (255.255.255.0). Zone alarm off for file sharing, on for internet sharing.

    LAPTOP
    ---------
    LAN connection, tcp(192.168.0.2), subnet as above, default gateway(192.168.0.1), and finally preferred DNS as the dns of the dsl provider.

    So simple.

IMN logo majestic logo threadwatch logo seochat tools logo