#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0

    Three routers/extenders on same subnet


    Hi there

    I've had some difficulty connecting to an SSH server running on a Buffalo WHR-G54S router, running Tomato firmware, although I've now managed to connect to it running Putty on the PC upstairs using the no-ip.org dynamic address and port 2222, which is forwarded to the Buffalo and also with SSH AutoTunnel on my Android phone.

    It's a rather complicated setup, as the main modem/router is a Virgin Media box, which the PC is wired to and that runs on 192.168.0.1 and it's DHCP server supplies address to the two PCs and the odd mobile device that's connected. Then there's a TP-Link Wireless Extender downstairs and that's set to 192.168.0.253, with the Gateway set to 192.168.0.1 and it's DHCP server disabled.

    Then we come to the Buffalo, which is running in Wireless Client mode to connect to the the TP-Link Extender. This has settings for the WAN side which are set to 192.168.0.2, Gateway 192.168.0.1. For the LAN side, it's set to 192.168.1.254 and it's DHCP server is set to 192.168.1.1 - 192.168.1.100.

    With it setup like that, I can access the Buffalo, TP-Link and Virgin Media routers GUIs from the laptop wired to the Buffalo, even though the VM router is on a different subnet to the other two.

    I tried setting the LAN side to 192.168.0.252 and the DHCP server to 192.168.0.85 - 192.168.0.100, so that all devices were on the same subnet and accessible from each other but that didn't work well at all. I also tried disabling the DHCP server and manually setting the IP address and gateway on the laptop wired to the Buffalo but that didn't work any better and I could only access the Buffalo on that IP but no longer the TP-Link on 192.168.0.253.

    So is it not possible to have the Buffalo on the same subnet (192.168.0.x) as the VM router and just have the latter run the DHCP server to supply IP addresses to any wireless devices that connect to it or the TP-Link extender and the wired devices (TV, Blu-ray) that are connected to the Buffalo?
  2. #2
  3. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    Another problem I've run into is that whilst I was able to connect to the SSH server whilst at my parents house and connected to the Virgin Media router, so on the same network, at my own house connected to my own router, it's not possible to connect, so any ideas why that might be?
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    I think the issue you're having is that the TP-Link would have to have a static route telling it how to get back to the 0.1 network from the 1.1 network. I'm not sure if that device has the capacity to do that since it's just an extender and not a router.
  6. #4
  7. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    Yeah, you're probably right, although I seem to recall running into the same problem (not being able to access the Buffalo GUI from the Virgin Media-connected PC) before I added the TP-Link extender into the mix. I didn't really try very hard to fix it then though, so it might have been fairly simple at that point.
  8. #5
  9. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    I had some problems with my Mum's new tablet on the network today. It was OK in the afternoon but then later, it appeared to be able to connect to either the extender or the router upstairs but then wasn't getting an IP address, so was obviously unusable. I tried rebooting just in case connecting to the VPN with it had screwed with something but that didn't help and I was able to connect and get an IP address from public BT WiFi hotspots.

    At the same time, my phone was getting an IP address fine.

    I edited the DHCP server on the Virgin Media router to extend it from 16 to 35 addresses and after that, the tablet got an address again but that might have been a coincidence and it started having problems again later anyway. Then I rebooted the extender and it seemed OK again but I wasn't able to hang around and see if it stayed OK.

    I was wondering if it might help to enable the DHCP server on the extender. On the VM router it's only serving from 192.168.0.2 - 192.168.0.36 (only about four addresses are ever used out of that, at max), so could I enable the one on the extender and set it to serve from 192.168.0.100 - 192.168.0.110 or would having two DHCP servers, even serving different ranges, cause problems?
  10. #6
  11. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    bump, anyone?
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    875
    Rep Power
    276
    Assuming the VM router is the Internet-facing one;

    1. Does your TP extender extend wireless from VM router, or from Buffalo, or both?

    2. Is the Buffalo "hard-wired" (using ethernet cable) directly to your VM router?


    If answer to question 2 is YES, I suggest turning OFF all DHCP except for VM router.
    Unplug the cable from the WAN of the buffalo and connect it to one of the LAN ports of the Buffalo [after changing the LAN IP of Buffalo to 192.168.0.2 instead of .1.2) and strictly let the VM router do ALL of the DHCP.

    This will keep all devices on the same subnet and should negate any routing issues...and should also still allow you to use the SSH with your Buffalo [using the port 2222] assuming you have that port forwarded properly in the VM router [to your Buffalo's LAN IP].
  14. #8
  15. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    Yes, the VM router is the Internet-facing one.

    1. The TP extender only extends the wirless from the VM router, so that it can be picked up better by the Buffalo.

    2. The Buffalo isn't hard-wired to anything upstream, only the downstream devices (TV, etc).

    I can set the Buffalo LAN IP to 192.168.0.2, which would make it's LAN and WAN addresses identical as I didn't try that yet, only setting the LAN IP to 192.168.0.252.

    I don't think that could help with the problem of my Mum's tablet not getting an IP address from either the TP extender or the VM router, when my phone was able to. I wouldn't have thought I'd have got an IP on my phone if the router or extender were faulty and the tablet's brand new so that shouldn't have any problems but it might have just been acting up that day, so I'll have to check and see if it's still having problems, or maybe the VM router does have a fault that causes it to provide IPs for some devices but not others, which is why I was wondering if I should try enabling the DHCP server on the extender as well (but on a different range).
  16. #9
  17. No Profile Picture
    Contributing User
    Devshed Novice (500 - 999 posts)

    Join Date
    Oct 2009
    Location
    Nebraska, USA
    Posts
    875
    Rep Power
    276
    Originally Posted by doveman

    2. The Buffalo isn't hard-wired to anything upstream, only the downstream devices (TV, etc).
    Ah, OK, then, what I was suggesting probably wouldn't work.

    However, if the Buffalo is only being used as wireless client, and nothing is physically connected to its WAN port, there should be no reason to set any IP on its WAN interface as it shouldn't be getting used ( I believe ).
  18. #10
  19. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    7
    Rep Power
    0
    Originally Posted by DonR
    Ah, OK, then, what I was suggesting probably wouldn't work.

    However, if the Buffalo is only being used as wireless client, and nothing is physically connected to its WAN port, there should be no reason to set any IP on its WAN interface as it shouldn't be getting used ( I believe ).
    Hmm, I guess I could try and see if it will let me leave the WAN settings blank and just set the LAN IP to 192.168.0.2 then. I'm not sure if it considers the Wi-Fi section as the WAN though but there's no harm trying.

IMN logo majestic logo threadwatch logo seochat tools logo