#1
  1. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    2
    Rep Power
    0

    Setting up a 2600xm cisco as a broadband router.


    could someone take a look at this, it obtains an ip from my isp on eth 0/1 but any requests on 0/0 (local network) are not being forwarded, bit clueless, not sure if dns falls into this ???? can anyone assist.

    Code:
    midnight-2600xm#show running-config
    Building configuration...
    
    Current configuration : 1510 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname midnight-2600xm
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 zzzzzzzzzzzzzzzzzzzzzzzzz
    enable password zzzzzzzzzzzzzzz
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    ip host midnight-sol 2033 192.168.0.42
    ip host midnight-sol2 2034 192.168.0.42
    ip host midnight-sol3 2035 192.168.0.42
    ip host midnight-sol4 2036 192.168.0.42
    ip host midnight-sol5 2037 192.168.0.42
    ip host midnight-sol6 2038 192.168.0.42
    ip host cisco-2960t 2039 192.168.0.42
    ip host cisco-877w 2040 192.168.0.42
    ip host apc-2200va 2041 192.168.0.42
    !
    !
    !
    controller E1 0/1
    !
    !
    !
    interface ATM0/0
     description BT_ADSL_Line
     no ip address
     shutdown
     no atm ilmi-keepalive
     dsl operating-mode auto
     pvc 0/38
      encapsulation aal5mux ppp dialer
     !
    !
    interface FastEthernet0/0
     ip address 192.168.0.41 255.255.255.0
     ip nat inside
     speed 100
     full-duplex
     no cdp enable
     no mop enabled
    !
    interface FastEthernet0/1
     ip address dhcp
     ip nat outside
     speed auto
     full-duplex
     no cdp enable
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
    !
    no ip http server
    ip nat inside source list 1 interface FastEthernet0/1 overload
    !
    !
    control-plane
    !
    !
    line con 0
    line 33 48
     no flush-at-activation
     transport preferred telnet
     transport input all
     stopbits 1
     flowcontrol hardware
    line aux 0
    line vty 0 4
     password falcon
     login
    !
    !
    end
    
    midnight-2600xm#
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Unless I missed it in the code, I don't see that you created the actual access list that your ip nat source list 1 statement is referencing.

    i.e., access list 1 192.168.1.0/24 (been a while so that might not be the exact syntax). Cisco has a pretty good walk through on their site that will tell you how to do it.
  4. #3
  5. No Profile Picture
    Registered User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Nov 2013
    Posts
    2
    Rep Power
    0
    this is my newest revision, still not much luck though

    Code:
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname midnight-2600xm
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 zzzzzzzzzzzzz
    enable password zzzzzzzzzzz
    !
    no aaa new-model
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    ip host midnight-sol 2033 192.168.0.42
    ip host midnight-sol2 2034 192.168.0.42
    ip host midnight-sol3 2035 192.168.0.42
    ip host midnight-sol4 2036 192.168.0.42
    ip host midnight-sol5 2037 192.168.0.42
    ip host midnight-sol6 2038 192.168.0.42
    ip host cisco-2960t 2039 192.168.0.42
    ip host cisco-877w 2040 192.168.0.42
    ip host apc-2200va 2041 192.168.0.42
    !
    !
    !
    controller E1 0/1
    !
    !
    !
    interface ATM0/0
     description BT_ADSL_Line
     no ip address
     shutdown
     no atm ilmi-keepalive
     dsl operating-mode auto
     pvc 0/38
      encapsulation aal5mux ppp dialer
     !
    !
    interface FastEthernet0/0
     ip address 192.168.0.40 255.255.255.0
     ip nat inside
     speed 100
     full-duplex
     no cdp enable
     no mop enabled
    !
    interface FastEthernet0/1
     ip address dhcp
     ip nat outside
     speed auto
     full-duplex
     no cdp enable
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
    !
    no ip http server
    ip nat inside source list 1 interface FastEthernet0/1 overload
    ip nat inside source static tcp 192.168.0.31 22 192.168.0.31 22 extendable
    ip nat inside source static tcp 192.168.0.31 80 192.168.0.31 80 extendable
    !
    access-list 1 permit 0.0.0.0 192.168.0.100
    !
    control-plane
    !
    banner motd ^C
    ******************************************
    * Unauthorized access prohibited
    *
    * You are connected to CISCO 2600xm Router
    * at ip 192.168.0.40.
    *
    ******************************************
    ^C
    !
    line con 0
    line 33 48
     no flush-at-activation
     transport preferred telnet
     transport input all
     stopbits 1
     flowcontrol hardware
    line aux 0
    line vty 0 4
     password falcon
     login
    !
    !
    end
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    Can you ping 8.8.8.8 from a computer or the Cisco device?

IMN logo majestic logo threadwatch logo seochat tools logo