#1
  1. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    5
    Rep Power
    0

    Slow file transfer


    I have two Mac G4s going through a a switch with two one gig ports and the transfer speed is very slow. When I connect them directly with a crossover cable, all is well.

    The switch is connected to a one meg cable modem, no router.

    Anyone know why the switch is slowing it down?
  2. #2
  3. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    108
    Rep Power
    11
    Switch = ?
    Very Slow = ?
    Direct Connect Speed = ?
  4. #3
  5. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    5
    Rep Power
    0
    dbasnett:

    Switch = ? Do you mean make model?
    Very slow = As in estimated download time of a 67 m file of seven hours
    Direct connect speed = same file down in minutes

    More info: When I first set up sharing, I was using a 10 meg hub and realised the transfer speeds were unrealistic. I updated the hub to a switch, which has two one-gig ports, in the hope that this would fix it, but it's made no difference.

    The older G4 has a 100 meg ethernet card and the new one has a one gig card. Clearly, when connected directly, they're capable of acceptable transfere speed, I'm just curious why the hub or switch slows the process to a snail's pace.

    Never networked machines before. Thanks in advance.
  6. #4
  7. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    108
    Rep Power
    11
    Yes, switch make and model. Is the file 67m bits or bytes?
  8. #5
  9. No Profile Picture
    network dude
    Devshed Intermediate (1500 - 1999 posts)

    Join Date
    Dec 2003
    Posts
    1,698
    Rep Power
    114
    Sounds to me to be a buffer overflow issue that you will see with large file transfers when going from a 1000Mbps to 100Mbps as the faster NIC will over run the buffers in the switch causing the switch to defer packets and the sending machine to retransmit. when you connect with a cross-over cable the 1000 NIC will auto sense the connection and slow to 100Mbps so both machines are at 100Mbps. Try manualy setting the switch and two NIC's to 100 full. if you can not adjust the switch and it is in auto detect for speed and duplex it will cause framing errors as if you set one manualy both the switch port and NIC should be set static.
  10. #6
  11. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    5
    Rep Power
    0
    dbasnett,

    Thanks for your kind and friendly response. That's 67 mbytes. Switch? Darn, I'm at the office right now, I'll check when I go home.

    Juniperr,
    Thanks to you too. Both the switch and hub are very basic devices--no configuration control, as far as I can see. BTW, the data is going FROM the slow machine TO the faster one (if it makes a difference).
    Would a router help? I have muliple machine permission from my ISP, so I didn't think I needed one.
    Last edited by HnR; January 7th, 2004 at 06:31 PM.
  12. #7
  13. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    108
    Rep Power
    11
    One other thing, what are you using for file transfer?
  14. #8
  15. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    5
    Rep Power
    0
    Hi dbasnett,

    Guess what? I was tired when I got home last night and clean forgot to check the switch details. It's 9:00 AM Friday here, I'll do it at the weekend for sure.

    I'm using file sharing in OS X (panther).
  16. #9
  17. No Profile Picture
    Junior Member
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jan 2004
    Posts
    5
    Rep Power
    0
    The device: Buffalo switching hub LSW-TS6GT2. It has six 100M ports and two 1000M. It says 'auto MDIX' on the facia. I have the two G4s connected through the fast ports (sorry if I'm stating the obvious).

    Thanx in advance, guys
  18. #10
  19. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Dec 2003
    Posts
    108
    Rep Power
    11
    FYI - I could not find any reference to the product you mentioned. Try connecting both machines to the 100M ports and see how it performs.

IMN logo majestic logo threadwatch logo seochat tools logo