Hi all,
I am having a problem with a connection between my webserver and websocket server. My webserver is running Apache/PHP 5.5 and is using the latest ZeroMQ bindings to connect and push a message to a websocket server running Apache and Ratchet/ZeroMQ.

Everything has been fine until recently when I noticed the messages not being received by the websocket server. I have been able to determine that the problem occurs when the connection is being established, and a tcpdump on the websocket server produces the following output:

Code:
15:50:11.376542 IP 52.24.53.169.34920 > 172.31.35.165.personal-agent: Flags [S], seq 825114437, win 26883, options [mss 8961,sackOK,TS val 19325473 ecr 0,nop,wscale 7], length 0
15:50:11.517063 IP 52.24.53.169.34921 > 172.31.35.165.personal-agent: Flags [S], seq 3472993605, win 26883, options [mss 8961,sackOK,TS val 19325509 ecr 0,nop,wscale 7], length 0
15:50:11.694600 IP 52.24.53.169.34922 > 172.31.35.165.personal-agent: Flags [S], seq 1407587143, win 26883, options [mss 8961,sackOK,TS val 19325553 ecr 0,nop,wscale 7], length 0
15:50:11.843959 IP 52.24.53.169.34923 > 172.31.35.165.personal-agent: Flags [S], seq 2050204121, win 26883, options [mss 8961,sackOK,TS val 19325590 ecr 0,nop,wscale 7], length 0
15:50:11.992493 IP 52.24.53.169.34924 > 172.31.35.165.personal-agent: Flags [S], seq 856661145, win 26883, options [mss 8961,sackOK,TS val 19325627 ecr 0,nop,wscale 7], length 0
15:50:12.101039 IP 52.24.53.169.34925 > 172.31.35.165.personal-agent: Flags [S], seq 533492020, win 26883, options [mss 8961,sackOK,TS val 19325655 ecr 0,nop,wscale 7], length 0
15:50:12.237696 IP 52.24.53.169.34926 > 172.31.35.165.personal-agent: Flags [S], seq 325726346, win 26883, options [mss 8961,sackOK,TS val 19325689 ecr 0,nop,wscale 7], length 0
15:50:12.378156 IP 52.24.53.169.34927 > 172.31.35.165.personal-agent: Flags [S], seq 2160886297, win 26883, options [mss 8961,sackOK,TS val 19325724 ecr 0,nop,wscale 7], length 0
15:50:12.542662 IP 52.24.53.169.34928 > 172.31.35.165.personal-agent: Flags [S], seq 2496136685, win 26883, options [mss 8961,sackOK,TS val 19325765 ecr 0,nop,wscale 7], length 0
15:50:12.696331 IP 52.24.53.169.34929 > 172.31.35.165.personal-agent: Flags [S], seq 1470958326, win 26883, options [mss 8961,sackOK,TS val 19325803 ecr 0,nop,wscale 7], length 0
15:50:12.846757 IP 52.24.53.169.34930 > 172.31.35.165.personal-agent: Flags [S], seq 300350422, win 26883, options [mss 8961,sackOK,TS val 19325841 ecr 0,nop,wscale 7], length 0...

52.24.53.169  webserver
172.31.35.165  Ratchet websocket server
This continues on indefinitely and the connection appears to never be made. I am fairly new to the networking side of things so I was wondering if anyone can see any red flags in this output?

Thanks for any input, I'm at a loss here.