#1
  1. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    260
    Rep Power
    0

    Windows 7 Pro 'fileserver' and Windows XP access problem


    Hi all, I have setup a small 'Workgroup' network setup and I have an issue.

    I have a main computer, which runs Windows 7, that is a kind of fileserver and backupserver. I have 2 other Windows 7 Pro machines that sends their backup automatically every night. All 3 machines has passwords protected accounts and the fileserver\backupserver has his account + all other accounts from other machines, so they have access to the 'server'. Everything runs fine without the 'homegroup' (disabled since my network is flagged as 'Work' network and not 'Home' network.

    Then, one XP machine arrived, and I can't access my Windows 7 server shares. I can ping the machine, but if I try the hostname or direct IP, is says that XXXX is not accessible. you might not have permission to use this netwrk resource.

    On the Windows 7 machine, the Windows XP account is on both side, I tried to shut down AV (MSEssentials) and turned off firewall, nothing to do, the XP machine can't see shares.

    - Turn on network discovery = checked
    - Turn on file and printer sharing = checked
    - Turn on sharing so anyone with ... files in the public folders = checked
    - etc.

    Everything 'should' be fine, why I can't access my W7 shares and shared printer from my XP machine, is there a trick.

    I googled, tried 4-5 tutorials and nothing worked, thanks all for your help!!!
  2. #2
  3. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,439
    Rep Power
    4539
    You didn't mention what versions of W7 and XP you're using. From your description it sounded like you're using W7 Professional (or whatever the equivalent of XP Pro is called in W7), and using network usernames/passwords (i.e., 'simple file sharing' is off).

    If that's the case, and if your XP is XP Home you may have problems. XP Home uses the Guest account for network access as far as I know.

    Also, verify that the XP machine is in the same network workgroup as the other computers, verify file & printer sharing is enabled on the XP machine.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  4. #3
  5. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    260
    Rep Power
    0
    Sorry, forgot to mention, it is Windows 7 PRO and Windows XP PRO.

    They are both under WORKGROUP.

    File & Printer Sharing is on on the XP machine.

    Both have firewall disabled and AV disabled, just to make the tests. Network user/pass is also off.

    I think everything is well done, but maybe I'm missing something somewhere, it should work.
  6. #4
  7. No Profile Picture
    Grumpier old Moderator
    Devshed Supreme Being (6500+ posts)

    Join Date
    Jun 2003
    Posts
    14,439
    Rep Power
    4539
    Did you check your 'simple file sharing' setting, at least on the xp machine?

    On xp from a command prompt issue 'net view' and/or 'net view \\<w7name> (or IP)' (without the quotes)

    And if you're trying to use an administrative share (like c$) they were turned off in w7.
    ======
    Doug G
    ======
    Bartender to Rene Descartes "have another beer?" Descartes: "I think not" and he vanished.
    --Alfred Bester
  8. #5
  9. No Profile Picture
    Contributing User
    Devshed Regular (2000 - 2499 posts)

    Join Date
    May 2004
    Location
    surfing the interwebz
    Posts
    2,410
    Rep Power
    2005
    On the Windows 7 Pro machine that is acting as a server, go to Homegroup>Advanced Sharing Options>make sure the following is enabled:

    1. Turn on Network Discovery (probably already active)
    2. Turn on File/Print Sharing (again probably already active)
    3. Password Protected Sharing (not Public folder sharing), turn this off.

    edit: Take a look here if you still have trouble.
    Last edited by seack79; March 1st, 2012 at 07:28 PM.
  10. #6
  11. No Profile Picture
    Contributing User
    Devshed Newbie (0 - 499 posts)

    Join Date
    Jul 2004
    Posts
    260
    Rep Power
    0
    Ok, it worked, but I changed nothing from what I've done. I just came back later and it was working..., weird.

    Thanks a lot to all of you for time/help.!

IMN logo majestic logo threadwatch logo seochat tools logo